Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6045

copy-to-slave hangs copying binary (.exe) file

    XMLWordPrintable

Details

    Description

      Trying to copy a binary file (.exe) from windows server to windows slave make job hang indefinitely and slave appear 'offline'.

      In this case, the only solution is to:

      • net stop hudsonslave
      • net start hudsonslave
      • modifiy job so that it copies a text file (instead of the .exe)
      • run it
      • revert job modification, copying the .exe again
      • run it

      Then it works for some times again (.exe file can be copied) if starting jobs manually.

      But at least the next morning (i.e., when job has been triggered automatically), the job is hanging again on the slave (during .exe is beeing copied). In this case, the slave appears 'offline'

      Attachments

        Activity

          aeschbacher aeschbacher created issue -
          aeschbacher aeschbacher added a comment -

          some other comments that might help:

          • size of the .exe is about 1,9 MB
          • when the described problem occurs, even a reboot of slave and/or master does not help (I really need to copy a text file first)
          aeschbacher aeschbacher added a comment - some other comments that might help: size of the .exe is about 1,9 MB when the described problem occurs, even a reboot of slave and/or master does not help (I really need to copy a text file first)
          rseguy Romain Seguy added a comment -

          What are the Hudson and the plugin versions you are running?

          rseguy Romain Seguy added a comment - What are the Hudson and the plugin versions you are running?
          aeschbacher aeschbacher added a comment -

          Hudson ver.1.352
          copy-to-slave 1.2

          aeschbacher aeschbacher added a comment - Hudson ver.1.352 copy-to-slave 1.2
          rseguy Romain Seguy added a comment -

          I guess the issue is indeed caused by a bug in Hudson core with , cf. JENKINS-5977. I'm going to add a workaround to "fix" that.

          rseguy Romain Seguy added a comment - I guess the issue is indeed caused by a bug in Hudson core with , cf. JENKINS-5977 . I'm going to add a workaround to "fix" that.
          rseguy Romain Seguy made changes -
          Field Original Value New Value
          Status Open [ 1 ] In Progress [ 3 ]

          Code changed in hudson
          User: : rseguy
          Path:
          trunk/hudson/plugins/copy-to-slave/pom.xml
          trunk/hudson/plugins/copy-to-slave/src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToMasterNotifier.java
          trunk/hudson/plugins/copy-to-slave/src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToSlaveBuildWrapper.java
          trunk/hudson/plugins/copy-to-slave/src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToSlaveUtils.java
          trunk/hudson/plugins/copy-to-slave/src/main/webapp/JENKINS-5977/deleteme.tmp
          http://jenkins-ci.org/commit/34322
          Log:
          [FIXED JENKINS-6045]

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : rseguy Path: trunk/hudson/plugins/copy-to-slave/pom.xml trunk/hudson/plugins/copy-to-slave/src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToMasterNotifier.java trunk/hudson/plugins/copy-to-slave/src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToSlaveBuildWrapper.java trunk/hudson/plugins/copy-to-slave/src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToSlaveUtils.java trunk/hudson/plugins/copy-to-slave/src/main/webapp/ JENKINS-5977 /deleteme.tmp http://jenkins-ci.org/commit/34322 Log: [FIXED JENKINS-6045]
          scm_issue_link SCM/JIRA link daemon made changes -
          Resolution Fixed [ 1 ]
          Status In Progress [ 3 ] Resolved [ 5 ]
          rseguy Romain Seguy added a comment -

          Will be delivered today in copy-to-slave 1.2.1.

          rseguy Romain Seguy added a comment - Will be delivered today in copy-to-slave 1.2.1.
          rseguy Romain Seguy made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

          Code changed in jenkins
          User: rseguy
          Path:
          README.md
          src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToMasterNotifier.java
          src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToSlaveBuildWrapper.java
          src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToSlaveUtils.java
          src/main/webapp/HUDSON-5977/deleteme.tmp
          http://jenkins-ci.org/commit/copy-to-slave-plugin/1bd4d393856c3ce001f08af187f6601366f0509c
          Log:
          [FIXED JENKINS-6045] Dropped fix for JENKINS-6045 since required Jenkins version (1.409) includes it

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: rseguy Path: README.md src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToMasterNotifier.java src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToSlaveBuildWrapper.java src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToSlaveUtils.java src/main/webapp/HUDSON-5977/deleteme.tmp http://jenkins-ci.org/commit/copy-to-slave-plugin/1bd4d393856c3ce001f08af187f6601366f0509c Log: [FIXED JENKINS-6045] Dropped fix for JENKINS-6045 since required Jenkins version (1.409) includes it

          Code changed in jenkins
          User: rseguy
          Path:
          README.md
          src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToMasterNotifier.java
          src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToSlaveBuildWrapper.java
          src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToSlaveUtils.java
          src/main/webapp/HUDSON-5977/deleteme.tmp
          http://jenkins-ci.org/commit/copy-to-slave-plugin/1bd4d393856c3ce001f08af187f6601366f0509c
          Log:
          [FIXED JENKINS-6045] Dropped fix for JENKINS-6045 since required Jenkins version (1.409) includes it

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: rseguy Path: README.md src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToMasterNotifier.java src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToSlaveBuildWrapper.java src/main/java/com/michelin/cio/hudson/plugins/copytoslave/CopyToSlaveUtils.java src/main/webapp/HUDSON-5977/deleteme.tmp http://jenkins-ci.org/commit/copy-to-slave-plugin/1bd4d393856c3ce001f08af187f6601366f0509c Log: [FIXED JENKINS-6045] Dropped fix for JENKINS-6045 since required Jenkins version (1.409) includes it
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 136138 ] JNJira + In-Review [ 203871 ]

          People

            rseguy Romain Seguy
            aeschbacher aeschbacher
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: