Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60672

Timestamper plugin causes chrome frozen when there are too many console logs

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: timestamper-plugin
    • Environment:
      Jenkins ver. 2.204.1 Timestamper 1.10 Java OpenJDK 1.8.0_232-b09 Chrome 79.0.3945.88(64 bit) install Jenkins via kubernetes helm
    • Similar Issues:

      Description

      For a Free-Style job:
      Enable 'Add timestamps to the Console Output'
      Execute Shell:
      ```
      for i in $(seq 1 1 10000)
      do
      echo "Welcome $i times"
      done
      ```
      After build, open /consoleFull, scroll from top to bottom, Chrome will be frozen.

      When I disable timestamper, everything is ok.

      When I open /consoleText instead of /consoleFull, it is ok too.

      I tried install jenkins directly in ubuntu or centos, Chrome will be frozen too.

      I also tried FireFox and Edge, they won't be frozen and scroll smoothly.

        Attachments

          Activity

          cindertyson Andy Buckles added a comment -

          Thanks Basil!  Confirmed that the issue is fixed on my version of Chrome 80.0.3987.122. Definitely was previously broken with Chrome 79.

          dogin2006 Kaiyuan Zhao added a comment -

          Hi Basil Crow, I tried Chrome 80.0.3987.122, it seems ok now.

          When I create this issue, I was using Chrome 79.0.3945.88(64 bit)  described in 'Environment'

          basil Basil Crow added a comment -

          Hey Kaiyuan Zhao, I just ran the test you provided and could not reproduce a freeze in Chromium 80.0.3987.122 (Official Build) snap (64-bit) on Ubuntu 19.10 eoan. Could you please try upgrading Chrome to version 80.x and see if that resolves the issue? If not, could you please provide more information about your operating system?


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            dogin2006 Kaiyuan Zhao
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: