Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60911

email-ext-plugin not loading files through config-file-provider-plugin when defined at folder level

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      2.69

      Description

      Since JENKINS-18203, it's possible to refer to files (template, script, etc...) to be used by email-ext-plugin and emailext-template-plugin from files defined through config-file-provider-plugin by using the "managed:" prefix.

      The issue is that the "managed:" syntax is working fine only when such configuration is done at the top level of Jenkins.
      Whereas the config-file-provider-plugin enables also to configure such files at folder level (cf. cloudbees-folder-plugin), with lowest folder level taking precedence in case of files with same name defined at several levels of the folder tree, this "managed:" syntax does not work in such case like it should.

      I'm providing a solution in a GitHub pull-request with unit-tests in a separated commit, so that anyone can figure out the failing scenarii before the fix commit.

        Attachments

          Activity

          gcernier_amadeus Guillaume CERNIER created issue -
          gcernier_amadeus Guillaume CERNIER made changes -
          Field Original Value New Value
          Assignee Francisco Fernández [ fcojfernandez ] Guillaume CERNIER [ gcernier_amadeus ]
          gcernier_amadeus Guillaume CERNIER made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          gcernier_amadeus Guillaume CERNIER made changes -
          Description Since JENKINS-18203, it's possible to refer to files (template, script, etc...) to be used by {{email-ext-plugin}} and {{emailext-template-plugin}} from files defined through config-file-provider-plugin by using the "{{managed:}}" prefix.

          The issue is that the "{{managed:}}" syntax is working fine only when such configuration is done at the top level of Jenkins.
           Whereas the {{config-file-provider-plugin}} enables also to configure such files at folder level (cf. {{cloudbees-folder-plugin}}), with lowest folder level taking precedence in case of files with same name defined at several levels of the folder tree, this "{{managed:}}" syntax does not work in such case like it should.

          I'm providing a solution in a GitHub pull-request with unit-tests in a separated commit, so that anyone can figure out the failing scenarii before the fix commit.
          Since JENKINS-18203, it's possible to refer to files (template, script, etc...) to be used by {{email-ext-plugin}} and {{emailext-template-plugin}} from files defined through config-file-provider-plugin by using the "{{managed:}}" prefix.

          The issue is that the "{{managed:}}" syntax is working fine only when such configuration is done at the top level of Jenkins.
           Whereas the {{config-file-provider-plugin}} enables also to configure such files at folder level (cf. {{cloudbees-folder-plugin}}), with lowest folder level taking precedence in case of files with same name defined at several levels of the folder tree, this "{{managed:}}" syntax does not work in such case like it should.

          I'm providing a solution in a [GitHub pull-request|https://github.com/jenkinsci/email-ext-plugin/pull/196] with unit-tests in a separated commit, so that anyone can figure out the failing scenarii before the fix commit.
          gcernier_amadeus Guillaume CERNIER added a comment -

          Fixed by email-ext-plugin's PR #196 on GitHub.

          gcernier_amadeus Guillaume CERNIER made changes -
          Resolution Fixed [ 1 ]
          Status In Progress [ 3 ] Fixed but Unreleased [ 10203 ]
          gcernier_amadeus Guillaume CERNIER made changes -
          Comment [ The [GitHub pull-request|https://github.com/jenkinsci/email-ext-plugin/pull/196] fixing the issue. ]
          basil Basil Crow added a comment -

          Released in 2.69.

          basil Basil Crow made changes -
          Released As 2.69
          Status Fixed but Unreleased [ 10203 ] Closed [ 6 ]

            People

            Assignee:
            gcernier_amadeus Guillaume CERNIER
            Reporter:
            gcernier_amadeus Guillaume CERNIER
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: