Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-61164

Configure Clouds - no credentials visible for vSphere Cloud

    XMLWordPrintable

Details

    Description

      After updating to new jenkins version, the clouds configuration page has moved.

      When accessing the new config page, the "Credentials" dropddown for my existing vSphere Cloud is "none". Before the update, I had configured credentails for that cloud. Also if I open the drop-down, the list only contains "-none". Also if I click "Add" and add new Global credentials, the DropDown keeps empty.

      Attachments

        Issue Links

          Activity

            dhoerner Daniel Hoerner created issue -
            dhoerner Daniel Hoerner made changes -
            Field Original Value New Value
            Description After updating to new jenkins version, the clouds configuration page has moved.

            When accessing the new config page, the "Credentials" dropddown for my existing vSphere Cloud is "-none-". Before the update, I had configured credentails for that cloud. Also if I open the drop-down, the list only contains "-none". Also if I click "Add" and add new Global credentials, the DropDown keeps empty.
            After updating to new jenkins version, the clouds configuration page has moved.

            When accessing the new config page, the "Credentials" dropddown for my existing vSphere Cloud is "none". Before the update, I had configured credentails for that cloud. Also if I open the drop-down, the list only contains "-none". Also if I click "Add" and add new Global credentials, the DropDown keeps empty.
            medianick Nick Jones made changes -
            Link This issue duplicates JENKINS-61131 [ JENKINS-61131 ]
            medianick Nick Jones made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
            medianick Nick Jones made changes -
            Status Fixed but Unreleased [ 10203 ] Closed [ 6 ]
            pjdarton pjdarton added a comment -

            FAO anyone watching: this will be fixed in the next release.
            In the meantime, anyone affected by this issue can grab an as-yet-unreleased build from https://ci.jenkins.io/job/Plugins/job/vsphere-cloud-plugin/job/master/lastSuccessfulBuild/

            pjdarton pjdarton added a comment - FAO anyone watching: this will be fixed in the next release. In the meantime, anyone affected by this issue can grab an as-yet-unreleased build from https://ci.jenkins.io/job/Plugins/job/vsphere-cloud-plugin/job/master/lastSuccessfulBuild/
            guy_rawsthorn Guy Rawsthorn added a comment -

            Hi pjdarton, thanks for the update. We are experiencing this issue where credentials are not shown in the dropdown, therefore, cannot be certain of our connection to vSphere. Is there an ETA on the next release? 

            Rdgs

            guy_rawsthorn Guy Rawsthorn added a comment - Hi pjdarton , thanks for the update. We are experiencing this issue where credentials are not shown in the dropdown, therefore, cannot be certain of our connection to vSphere. Is there an ETA on the next release?  Rdgs
            pjdarton pjdarton added a comment -

            No ETA; vSphere plugin maintenance (i.e. building, testing and releasing new versions) is something I do in my "spare" time at work (and there's precious little of that at present).

            There is, however, something you (or anyone else watching this) can do to speed things up:

            • download the .hpi file from the URL above and install it using the "advanced" tab on the manage plugins page.
            • test it
            • let me know if it fixes the problem for you
              If you can do that then it'll give me confidence that the fix works and is worth releasing officially, meaning I can get a release out much sooner.

            If you can't help with that then you'll have to wait until I have the time to do all that myself unaided ... and that might be a while.

            pjdarton pjdarton added a comment - No ETA; vSphere plugin maintenance (i.e. building, testing and releasing new versions) is something I do in my "spare" time at work (and there's precious little of that at present). There is, however, something you (or anyone else watching this) can do to speed things up: download the .hpi file from the URL above and install it using the "advanced" tab on the manage plugins page. test it let me know if it fixes the problem for you If you can do that then it'll give me confidence that the fix works and is worth releasing officially, meaning I can get a release out much sooner. If you can't help with that then you'll have to wait until I have the time to do all that myself unaided ... and that might be a while.

            Thank you, with the downloaded hpi file the issue is solved.

            dhoerner Daniel Hoerner added a comment - Thank you, with the downloaded hpi file the issue is solved.
            guy_rawsthorn Guy Rawsthorn added a comment -

            Can confirm the upgrade works on my system too. Successfully shows the connection state to vSphere and the availability of the template.

            guy_rawsthorn Guy Rawsthorn added a comment - Can confirm the upgrade works on my system too. Successfully shows the connection state to vSphere and the availability of the template.
            pjdarton pjdarton added a comment -

            Thanks for that folks - much appreciated.
            On the basis of 2 confirmed "it works" reports, I've kicked off a release; it's uploaded and should start showing up within the next few hours.

            i.e. This is fixed in the 2.23 release which went out just now.

            pjdarton pjdarton added a comment - Thanks for that folks - much appreciated. On the basis of 2 confirmed "it works" reports, I've kicked off a release; it's uploaded and should start showing up within the next few hours. i.e. This is fixed in the 2.23 release which went out just now.

            People

              Unassigned Unassigned
              dhoerner Daniel Hoerner
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: