Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-61757

Global Variable Reference HTML documentation strips <pre> tags

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: pipeline
    • Labels:
      None
    • Similar Issues:

      Description

      After quite some time I accidentally checked the "Pipeline Syntax > Global Variable Reference" for my shared Jenkins pipeline library and saw that the "<pre>" tags are now (unfortunately I can't remember when it was still OK, I just know that it used to be OK for a long time) stripped. Since it is about documentation of usage of shared pipeline library I claim that multi-line coding examples in such "<pre>"tags is fairly common...

      Example: For a file called "acme.txt" with the following content

      ...
          <p>
          Example:
            <pre>
        acme.build {
          node {
            ...
          }
        }
            </pre>
          </p>
      ...
      

      ..., the resulting HTML will looks like:

      ...
      <p>
          Example:
            </p>
        acme.build {
          node {
            ...
          }
        }
      ...
      

      And using an additional "<code>" inside the "<pre>" section, does not help either. But at least is kept...

        Attachments

          Issue Links

            Activity

            reinholdfuereder Reinhold Füreder created issue -
            reinholdfuereder Reinhold Füreder made changes -
            Field Original Value New Value
            Description After quite some time I accidentally checked the "Pipeline Syntax > Global Variable Reference" for my shared Jenkins pipeline library and saw that the "<pre>" tags are now (unfortunately I can't remember when it was still OK, I just know that it used to be OK for a long time) stripped. Since it is about documentation of usage of shared pipeline library I claim that multi-line coding examples in such "<pre>"tags is fairly common...

            Example: For a file called "acme.txt" with the following content

            {{...
                <p>
                Example:
                  <pre>
              acme.build {
                node {
                  ...
                }
              }
                  </pre>
                </p>
            ...}}

            ..., the resulting HTML will looks like:

            {{
            ...
            <p>
                Example:
                  </p>
              acme.build {
                node {
                  ...
                }
              }
            ...
            }}

            And using an additional "<code>" inside the "<pre>" section, does not help either. But at least is kept...
            After quite some time I accidentally checked the "Pipeline Syntax > Global Variable Reference" for my shared Jenkins pipeline library and saw that the "<pre>" tags are now (unfortunately I can't remember when it was still OK, I just know that it used to be OK for a long time) stripped. Since it is about documentation of usage of shared pipeline library I claim that multi-line coding examples in such "<pre>"tags is fairly common...

            Example: For a file called "acme.txt" with the following content
            {noformat}
            ...
                <p>
                Example:
                  <pre>
              acme.build {
                node {
                  ...
                }
              }
                  </pre>
                </p>
            ...
            {noformat}

            ..., the resulting HTML will looks like:
            {noformat}
            ...
            <p>
                Example:
                  </p>
              acme.build {
                node {
                  ...
                }
              }
            ...
            {noformat}

            And using an additional "<code>" inside the "<pre>" section, does not help either. But at least is kept...
            reinholdfuereder Reinhold Füreder made changes -
            Link This issue is related to JENKINS-62176 [ JENKINS-62176 ]
            reinholdfuereder Reinhold Füreder made changes -
            Link This issue duplicates JENKINS-62176 [ JENKINS-62176 ]
            reinholdfuereder Reinhold Füreder made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              reinholdfuereder Reinhold Füreder
              Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: