Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-61835

Credentials cannot be selected in the job config without having administer permissinos

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: bitbucket-plugin
    • Labels:
      None
    • Environment:
      Bitbucket version where the issue was reproducible: 1.1.5 and 1.1.11
      Jenkins version: CloudBees Jenkins Enterprise 2.190.3.2-rolling
    • Similar Issues:

      Description

      When configuring a freestyle job and selecting "Bitbucket Server" on "Source Code Management", the user cannot select any credentials from the dropdown menu if "administer" permissions are not granted. This has happened using Bitbucket plugin 1.1.5 and 1.1.11 with Jenkins 2.190.3.2-rolling.

      At the same time and same scenario, choosing git instead of bitbucket, the user was able to select credentials from the dropdown.

        Attachments

          Activity

          mgonzalez Manuel Gonzalez created issue -
          tzach_solomon Tzach Solomon added a comment -

          Manuel Gonzalez does this still happens? If so, can you please describe how to reproduce? 

          tzach_solomon Tzach Solomon made changes -
          Field Original Value New Value
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
          tzach_solomon Tzach Solomon made changes -
          Status Fixed but Unreleased [ 10203 ] Closed [ 6 ]

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            mgonzalez Manuel Gonzalez
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: