Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62381

Multibranch Project Doesn't Trigger Build

    XMLWordPrintable

Details

    Description

      When using Bitbucket server as a branch source in Multibranch pipeline, the webhook is properly created and sends the payload, but Jenkins does not trigger a build.

       

      Regular pipelines will properly trigger the build, just not multibranch pipelines.

       

      This is outputted in the logs:
      May 21, 2020 6:10:50 AM WARNING jenkins.scm.api.SCMHeadEvent$DispatcherImpl log
      SCMEventListener.onSCMHeadEvent(SCMHeadEvent) jenkins.branch.MultiBranchProject$SCMEventListenerImpl@1047d05 propagated an exception java.lang.NullPointerException at hudson.Util.getDigestOf(Util.java:634) at jenkins.plugins.git.AbstractGitSCMSource.getCacheEntry(AbstractGitSCMSource.java:1376) at jenkins.plugins.git.AbstractGitSCMSource.getCacheEntry(AbstractGitSCMSource.java:1211) at jenkins.plugins.git.AbstractGitSCMSource.doRetrieve(AbstractGitSCMSource.java:339) at jenkins.plugins.git.AbstractGitSCMSource.retrieve(AbstractGitSCMSource.java:561) at com.atlassian.bitbucket.jenkins.internal.scm.BitbucketSCMSource$CustomGitSCMSource.accessibleRetrieve(BitbucketSCMSource.java:447) at com.atlassian.bitbucket.jenkins.internal.scm.BitbucketSCMSource.retrieve(BitbucketSCMSource.java:189) at jenkins.scm.api.SCMSource._retrieve(SCMSource.java:373) at jenkins.scm.api.SCMSource.fetch(SCMSource.java:327) at jenkins.branch.MultiBranchProject$SCMEventListenerImpl.processHeadUpdate(MultiBranchProject.java:1683) at jenkins.branch.MultiBranchProject$SCMEventListenerImpl.onSCMHeadEvent(MultiBranchProject.java:1192) at jenkins.scm.api.SCMHeadEvent$DispatcherImpl.fire(SCMHeadEvent.java:246) at jenkins.scm.api.SCMHeadEvent$DispatcherImpl.fire(SCMHeadEvent.java:229) at jenkins.scm.api.SCMEvent$Dispatcher.run(SCMEvent.java:505) at jenkins.security.ImpersonatingScheduledExecutorService$1.run(ImpersonatingScheduledExecutorService.java:58) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748)
      May 21, 2020 6:14:59 AM INFO com.atlassian.bitbucket.jenkins.internal.http.HttpRequestExecutorImpl handleError
      Bitbucket - did not accept the request
      May 21, 2020 6:16:39 AM INFO com.atlassian.bitbucket.jenkins.internal.http.HttpRequestExecutorImpl handleError
      Bitbucket - did not accept the request

       

      Attachments

        Activity

          neilmfrench2 Neil French created issue -
          neilmfrench2 Neil French made changes -
          Field Original Value New Value
          Description When using Bitbucket server as a branch source in Multibranch pipeline, the webhook is properly created and sends the payload, but Jenkins does not trigger a build.

           

          This is outputted in the logs:
          May 21, 2020 6:10:50 AM WARNING jenkins.scm.api.SCMHeadEvent$DispatcherImpl log
          SCMEventListener.onSCMHeadEvent(SCMHeadEvent) jenkins.branch.MultiBranchProject$SCMEventListenerImpl@1047d05 propagated an exception java.lang.NullPointerException at hudson.Util.getDigestOf(Util.java:634) at jenkins.plugins.git.AbstractGitSCMSource.getCacheEntry(AbstractGitSCMSource.java:1376) at jenkins.plugins.git.AbstractGitSCMSource.getCacheEntry(AbstractGitSCMSource.java:1211) at jenkins.plugins.git.AbstractGitSCMSource.doRetrieve(AbstractGitSCMSource.java:339) at jenkins.plugins.git.AbstractGitSCMSource.retrieve(AbstractGitSCMSource.java:561) at com.atlassian.bitbucket.jenkins.internal.scm.BitbucketSCMSource$CustomGitSCMSource.accessibleRetrieve(BitbucketSCMSource.java:447) at com.atlassian.bitbucket.jenkins.internal.scm.BitbucketSCMSource.retrieve(BitbucketSCMSource.java:189) at jenkins.scm.api.SCMSource._retrieve(SCMSource.java:373) at jenkins.scm.api.SCMSource.fetch(SCMSource.java:327) at jenkins.branch.MultiBranchProject$SCMEventListenerImpl.processHeadUpdate(MultiBranchProject.java:1683) at jenkins.branch.MultiBranchProject$SCMEventListenerImpl.onSCMHeadEvent(MultiBranchProject.java:1192) at jenkins.scm.api.SCMHeadEvent$DispatcherImpl.fire(SCMHeadEvent.java:246) at jenkins.scm.api.SCMHeadEvent$DispatcherImpl.fire(SCMHeadEvent.java:229) at jenkins.scm.api.SCMEvent$Dispatcher.run(SCMEvent.java:505) at jenkins.security.ImpersonatingScheduledExecutorService$1.run(ImpersonatingScheduledExecutorService.java:58) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748)
          May 21, 2020 6:14:59 AM INFO com.atlassian.bitbucket.jenkins.internal.http.HttpRequestExecutorImpl handleError
          Bitbucket - did not accept the request
          May 21, 2020 6:16:39 AM INFO com.atlassian.bitbucket.jenkins.internal.http.HttpRequestExecutorImpl handleError
          Bitbucket - did not accept the request

           
          When using Bitbucket server as a branch source in Multibranch pipeline, the webhook is properly created and sends the payload, but Jenkins does not trigger a build.

           

          Regular pipelines will properly trigger the build, just not multibranch pipelines.

           

          This is outputted in the logs:
           May 21, 2020 6:10:50 AM WARNING jenkins.scm.api.SCMHeadEvent$DispatcherImpl log
           SCMEventListener.onSCMHeadEvent(SCMHeadEvent) jenkins.branch.MultiBranchProject$SCMEventListenerImpl@1047d05 propagated an exception java.lang.NullPointerException at hudson.Util.getDigestOf(Util.java:634) at jenkins.plugins.git.AbstractGitSCMSource.getCacheEntry(AbstractGitSCMSource.java:1376) at jenkins.plugins.git.AbstractGitSCMSource.getCacheEntry(AbstractGitSCMSource.java:1211) at jenkins.plugins.git.AbstractGitSCMSource.doRetrieve(AbstractGitSCMSource.java:339) at jenkins.plugins.git.AbstractGitSCMSource.retrieve(AbstractGitSCMSource.java:561) at com.atlassian.bitbucket.jenkins.internal.scm.BitbucketSCMSource$CustomGitSCMSource.accessibleRetrieve(BitbucketSCMSource.java:447) at com.atlassian.bitbucket.jenkins.internal.scm.BitbucketSCMSource.retrieve(BitbucketSCMSource.java:189) at jenkins.scm.api.SCMSource._retrieve(SCMSource.java:373) at jenkins.scm.api.SCMSource.fetch(SCMSource.java:327) at jenkins.branch.MultiBranchProject$SCMEventListenerImpl.processHeadUpdate(MultiBranchProject.java:1683) at jenkins.branch.MultiBranchProject$SCMEventListenerImpl.onSCMHeadEvent(MultiBranchProject.java:1192) at jenkins.scm.api.SCMHeadEvent$DispatcherImpl.fire(SCMHeadEvent.java:246) at jenkins.scm.api.SCMHeadEvent$DispatcherImpl.fire(SCMHeadEvent.java:229) at jenkins.scm.api.SCMEvent$Dispatcher.run(SCMEvent.java:505) at jenkins.security.ImpersonatingScheduledExecutorService$1.run(ImpersonatingScheduledExecutorService.java:58) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748)
           May 21, 2020 6:14:59 AM INFO com.atlassian.bitbucket.jenkins.internal.http.HttpRequestExecutorImpl handleError
           Bitbucket - did not accept the request
           May 21, 2020 6:16:39 AM INFO com.atlassian.bitbucket.jenkins.internal.http.HttpRequestExecutorImpl handleError
           Bitbucket - did not accept the request

           
          mhenschke_atlassian Martin Henschke made changes -
          Labels tracked-by-atlassian
          alibkord Ali Kord added a comment -

          Hi neilmfrench2,

          I haven't been able to reproduce this problem using the same versions (BbS 5.16.11, Jenkins 2.222.3, BbS Integration Plugin 1.1.0).

          Bitbucket (webhook) successfully triggers a re-scan of branches with no errors (or even warnings) in the log when I push to a new branch.

          Is the problem persistent? If so, can you please provide some more details about your configuration (e.g. screenshots of your SCM config, and any relevant Bitbucket logs)?

          Also, please try re-saving your configs and see if that fixes the problem.

          Thanks,

          Ali Kord

          alibkord Ali Kord added a comment - Hi neilmfrench2 , I haven't been able to reproduce this problem using the same versions (BbS 5.16.11, Jenkins 2.222.3, BbS Integration Plugin 1.1.0). Bitbucket (webhook) successfully triggers a re-scan of branches with no errors (or even warnings) in the log when I push to a new branch. Is the problem persistent? If so, can you please provide some more details about your configuration (e.g. screenshots of your SCM config, and any relevant Bitbucket logs)? Also, please try re-saving your configs and see if that fixes the problem. Thanks, Ali Kord
          alibkord Ali Kord made changes -
          Assignee Ali Kord [ alibkord ]
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
          mhenschke_atlassian Martin Henschke made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Fixed but Unreleased [ 10203 ] Reopened [ 4 ]
          mhenschke_atlassian Martin Henschke made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Reopened [ 4 ] Closed [ 6 ]

          People

            alibkord Ali Kord
            neilmfrench2 Neil French
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: