Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62806

active-choices plugin may break with tables-to-divs

    XMLWordPrintable

Details

    Description

      The active-choices plugin implements custom markup similar to the one of the f:checkbox widget that may break with the tables-to-divs changes: https://github.com/jenkinsci/active-choices-plugin/blob/9d26c1159205e0e7affdedb8b210c84dc6266e4d/src/main/resources/org/biouno/unochoice/common/checkboxContent.jelly

      It should be reviewed and fixed if needed.

      Attachments

        Issue Links

          Activity

            fqueiruga Félix Queiruga Balado created issue -
            fqueiruga Félix Queiruga Balado made changes -
            Field Original Value New Value
            Epic Link JENKINS-62437 [ 206431 ]
            fqueiruga Félix Queiruga Balado made changes -
            Component/s active-choices-plugin [ 20520 ]
            Component/s azure-commons-plugin [ 23148 ]
            fqueiruga Félix Queiruga Balado made changes -
            Description The _azure-comons_ plugin has a custom fork of the _f:block_ widget that may break with the tables-to-divs changes: [https://github.com/jenkinsci/azure-commons-plugin/blob/master/azure-commons-core/src/main/resources/lib/azure/radioBlock.jelly]

            It should be reviewed and fixed if needed.
            The _active-choices_ plugin implements custom markup similar to the one of the _f:checkbox_ widget that may break with the tables-to-divs changes: [https://github.com/jenkinsci/active-choices-plugin/blob/9d26c1159205e0e7affdedb8b210c84dc6266e4d/src/main/resources/org/biouno/unochoice/common/checkboxContent.jelly]

            It should be reviewed and fixed if needed.

            Hi fqueiruga,

            Thanks for reporting the issue. I wasn't aware of the migration, but found this page: https://www.jenkins.io/doc/developer/views/table-to-div-migration/

            In one of the paragraphs, it says:

            >For 99% of plugins they do not require any changes at all as they just use the standard jelly tags in Jenkins for their forms, such as f:entry, f:textbox, f:checkbox

            So f:checkbox should be OK I guess.

            But we are using tr/td, and also doing some custom JS code. So we may have to update some of our code once JENKINS-56109 gets merged/released.

            Linking the issue here for now

            kinow Bruno P. Kinoshita added a comment - Hi fqueiruga , Thanks for reporting the issue. I wasn't aware of the migration, but found this page: https://www.jenkins.io/doc/developer/views/table-to-div-migration/ In one of the paragraphs, it says: >For 99% of plugins they do not require any changes at all as they just use the standard jelly tags in Jenkins for their forms, such as f:entry, f:textbox, f:checkbox So f:checkbox should be OK I guess. But we are using tr/td, and also doing some custom JS code. So we may have to update some of our code once JENKINS-56109 gets merged/released. Linking the issue here for now
            kinow Bruno P. Kinoshita made changes -
            Link This issue is caused by JENKINS-56109 [ JENKINS-56109 ]

            I'd suggest to maybe use the `divBasedFormLayout` variable to conditionally load / run the proper JS code. Let us know if you find any issue.

            fqueiruga Félix Queiruga Balado added a comment - I'd suggest to maybe use the `divBasedFormLayout` variable to conditionally load / run the proper JS code. Let us know if you find any issue.

            kinow these changes has been released as of Jenkins 2.264 a week ago, so the plugin may be affected ever since.

            fqueiruga Félix Queiruga Balado added a comment - kinow these changes has been released as of Jenkins 2.264 a week ago, so the plugin may be affected ever since.

            Thanks fqueiruga ! I'm busy with other projects, but will have a break in December/January. But I suspect the plug-in will stay broken with 2.264+ for a little while (probably Q1/2021). cc ioannis

            kinow Bruno P. Kinoshita added a comment - Thanks fqueiruga ! I'm busy with other projects, but will have a break in December/January. But I suspect the plug-in will stay broken with 2.264+ for a little while (probably Q1/2021). cc ioannis
            kinow Bruno P. Kinoshita made changes -
            Assignee Bruno P. Kinoshita [ kinow ]
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
            timja Tim Jacomb made changes -
            Labels tables-to-divs-regression
            timja Tim Jacomb made changes -
            Link This issue is duplicated by JENKINS-64568 [ JENKINS-64568 ]

            In 2.5.2

            kinow Bruno P. Kinoshita added a comment - In 2.5.2
            kinow Bruno P. Kinoshita made changes -
            Status Fixed but Unreleased [ 10203 ] Resolved [ 5 ]
            kinow Bruno P. Kinoshita made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

            People

              kinow Bruno P. Kinoshita
              fqueiruga Félix Queiruga Balado
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: