Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63240

Configuration is gone after latest upgrade

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: core, packaging
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      When running the latest upgrade, I received the invalid keys message.  Upon looking up the issue, I found in the change log that I needed to update the public keys, which I did with no issues.  Then I re-ran the upgrade (yum upgrade jenkins) and did not receive any errors.  The Jenkins appeared to be starting up normally, but then I noticed that it was acting like I had never had Jenkins installed.  It was performing what looked like an initial install, which seemed even more confirmed when it asked me for the initial Administrator password.  After finishing starting up, I had no jobs any more, the configuration seemed to be completely gone.  Previously installed plugins were no longer there and jobs / configurations were all gone.  In looking into the directory structure on the OS, I still see my jobs defined, etc.   There doesn't seem to be any way of importing these jobs back in either.    Wish I could get my configuration back, or at a minimum, get my jobs imported back in.  I have several other Jenkins servers, but I do not want to upgrade any other servers for fear of loosing those configurations as well.

        Attachments

          Activity

          cautter Chad Utter created issue -
          oleg_nenashev Oleg Nenashev made changes -
          Field Original Value New Value
          Component/s packaging [ 20120 ]

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            cautter Chad Utter
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated: