Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63370

NullPointerException scanning Multi-Branch Pipeline stored in a personal repository with Bitbucket Server Integration

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      2.1.1

      Description

      Personal projects break Multi-Branch Pipeline jobs. May be triggered by modifying the job configuration in the UI.

      Symptoms:
      The Project field reverts from the tilde(~) prefixes username to the display name.
      NullPointerException during scan.

        Attachments

          Issue Links

            Activity

            brackett_tc Timothy Brackett created issue -
            mhenschke_atlassian Martin Henschke made changes -
            Field Original Value New Value
            Assignee Kristy Hughes [ khughes ]
            mhenschke_atlassian Martin Henschke made changes -
            Labels multi-branch multi-branch tracked-by-atlassian
            mhenschke_atlassian Martin Henschke added a comment -

            Hi Timothy, thanks for the bug report. This is a dupe (albeit a different symptom) to JENKINS-60274. This issue is resolved in 2.1.1, and a quick local test confirms I cannot replicate the issue. Feel free to reopen if the issue is persisting.

            mhenschke_atlassian Martin Henschke made changes -
            Link This issue duplicates JENKINS-60274 [ JENKINS-60274 ]
            mhenschke_atlassian Martin Henschke made changes -
            Released As 2.1.1
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              brackett_tc Timothy Brackett
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: