Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63434

Jenkins Unable to Start.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: _unsorted
    • Labels:
      None
    • Similar Issues:

      Description

      We have restarted Jenkins, but this time, Jenkins UI is stuck at "Please wait while Jenkins is getting ready to work ", When i check the Jenkins log /var/log/jenkins/jenkins.log, I see some jobs are running already, but the UI is not up. Please help anyone. This is our main Jenkins Instance,

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          This issue cannot be diagnosed without logs and stacktraces

          ianw Ian Williams added a comment -

          I often notice the IE browser (yes some ppl still have to use it) does not auto refresh, but an F5-click does it.

          vikaskoppi vikas koppineedi added a comment -

          Oleg Nenashev Ian Williams, I am not using IE, using chrome browser. Next it took 5 hours for the Jenkins UI to be completely up. All these 5 hours, the Jenkins jobs were getting triggered but not the UI. Please let me know which logs are required for troubleshooting, or at least let me know where to look at. I have checked the Jenkins /var/log/jenkins/jenkins.log, but it did not show any errors. Only thing i observed was loading jobs was taking a lot of time. What i heard from my colleague is could be too many Jenkins jobs with too many builds and to many logs. Was asked to clean up the jobs build history, which i did not perform yet.

          ianw Ian Williams added a comment -

          Do you see the message in the logs:

          INFO    hudson.WebAppMain$3#run: Jenkins is fully up and running

          That should be the signal the UI is available.

           

          vikaskoppi vikas koppineedi added a comment -

          Ian Williams, I saw that line like after 4 hours after Jenkins started running. 

          ianw Ian Williams added a comment -

          Do you see any messages of the form: Loading job <folder>/<jobname> (43.8%) ?

          We occasionally see that after a single restart where it seems to reprocess every job and log. Never really investigated why it does that, but weirdly have seen it go : (100.3%) or even  (109.7%).

          But for ~6000 jobs and 50000+ that still only takes 15 mins or so.

          I'd filter the logs prior to "fully up and running" message for anything odd and attach per Oleg.

          vikaskoppi vikas koppineedi added a comment -

          Figured out the root cause. SO I have my Jenkins home  on AWS EFS with burstable performance. THis was causing the read/write delays to the file system for the Jenkins Startup. 


            People

            Assignee:
            naveenboni Naveen Boni
            Reporter:
            vikaskoppi vikas koppineedi
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: