Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63586

xUnit publishing occasionally hangs indefinitely on windows agent

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: xunit-plugin
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

       

      The build after finishing testing, started to parse GoogleTest results with xUnit plugin.
      At some log it hanged indefinitely.
      It does occur once in 2 month with a rate around 600 build per day on windows machines.
      It did occurred with xUnit version 1.102 too, which was used previously. We hoped it would not occur with the new version.

      After killing the hanged process, the results are processed properly.

      23:45:13 INFO: Starting to record.
      23:45:13 INFO: Processing GoogleTest-1.8
      23:45:13 INFO: [GoogleTest-1.8] - 1 test report file(s) were found with the pattern '*result.xml' relative to '...' for the testing framework 'GoogleTest-1.8'.
      
      # killed process (3 processes were grouped together, from which I left running the jvm process and the connection initiator)
      
      10:54:58 INFO: Check 'Failed Tests' threshold.
      10:54:58 INFO: The total number of tests for the threshold 'Failed Tests' exceeds the specified "unstable threshold" value.
      10:54:58 INFO: Setting the build status to UNSTABLE
      10:54:58 INFO: Stopping recording.
      10:54:58 Build step 'Publish xUnit test result report' changed build result to UNSTABLE

      Seemingly unrelevant, but int the agent connection console, the following suspicious messages were:

      org.jvnet.winp.Native loadByUrlWarning: Failed to load dll from static location
      java.lang.UnsatisfiedLinkError: Native Library ... cache/jars/44/winp.x64....dll already loaded in another classloader
      ...
      at org.jvnet.winp.WinProcess.enableDebugPrivilege(WinProcess.java:245)
      ...

      Maybe related, but not obvious: https://issues.jenkins-ci.org/browse/JENKINS-20913

      Warning at function xunit:is-empty on line 51 SXWN9000: A function that computes atomic values should use xsl:sequence rather than xsl:value-of

      This did not appeared with the older xUnit version, but still had the hang.

       

       

        Attachments

          Activity

            People

            Assignee:
            nfalco Nikolas Falco
            Reporter:
            rudolf Rudolf Horvath
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: