Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64194

Blueocean plugin shouldn't depend on mercurial plugin

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Blueocean depends on a bitbucket plugin which needs a maintainer and that depends on mercurial which needs a maintainer. It really shouldn't depend on either since that bitbucket plugin must be out of date by a fair bit since Bitbucket itself doesn't even support mercurial anymore.

        Attachments

          Issue Links

            Activity

            lyda Kevin Lyda created issue -
            oleg_nenashev Oleg Nenashev added a comment -

            BlueOcean dependencies are a mess unfortunately. I do not think there is anybody actively working on this area at the moment.

            CC Jeremy Hartley

            dnusbaum Devin Nusbaum added a comment -

            I am closing this as a duplicate of JENKINS-62669. Mercurial support is gone starting in Blue Ocean 1.24.0 and BitBucket Branch Source 2.9.7.

            dnusbaum Devin Nusbaum made changes -
            Field Original Value New Value
            Link This issue duplicates JENKINS-62669 [ JENKINS-62669 ]
            dnusbaum Devin Nusbaum made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              lyda Kevin Lyda
              Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: