Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64445

Plugin manager throws NPE when using update centers without categories

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 2.270+
    • Similar Issues:
    • Released As:
      2.272

      Description

      This is a regression after JENKINS-64196 . Although the majority of Jenkins users rely on the https://github.com/jenkins-infra/update-center2 instance to retrieve the update details, there are other update center implementations out there. They do not implement all new features of the Jenkins update center.

      We do not have a strict update center API specification, and hence it is not possible to say what data would be returned by a particular update center. Some fields may be missing and end up as null values in the codebase. Categories is one of them, and hence https://github.com/jenkinsci/jenkins/pull/5051/files#diff-0dd3c7930da03922fff631a2cf06fbfda9b9bc688a4e5804fceda225147778a6R1399 may lead to NPE

       

       

       

       

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev created issue -
            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Description This is a regression after JENKINS-64196 . Although the majority of Jenkins users rely on the [https://github.com/jenkins-infra/update-center2] instance to retrieve the update details, there are other update center implementations out there. They do not implement all new features of the Jenkins update center.

            We do not have a strict update center API specification, and hence it is not possible to say what data would be returned by a particular update center. Some fields may be missing and end up as null values in the codebase. Categories is one of them

             

             

             
            This is a regression after JENKINS-64196 . Although the majority of Jenkins users rely on the [https://github.com/jenkins-infra/update-center2] instance to retrieve the update details, there are other update center implementations out there. They do not implement all new features of the Jenkins update center.

            We do not have a strict update center API specification, and hence it is not possible to say what data would be returned by a particular update center. Some fields may be missing and end up as null values in the codebase. Categories is one of them, and hence [https://github.com/jenkinsci/jenkins/pull/5051/files#diff-0dd3c7930da03922fff631a2cf06fbfda9b9bc688a4e5804fceda225147778a6R1399] may lead to NPE

             

             

             

             
            oleg_nenashev Oleg Nenashev made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            oleg_nenashev Oleg Nenashev made changes -
            Assignee Oleg Nenashev [ oleg_nenashev ]
            oleg_nenashev Oleg Nenashev made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is caused by JENKINS-64196 [ JENKINS-64196 ]
            markewaite Mark Waite made changes -
            Released As 2.272
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Resolved [ 5 ]
            markewaite Mark Waite made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              Assignee:
              oleg_nenashev Oleg Nenashev
              Reporter:
              oleg_nenashev Oleg Nenashev
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: