Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64749

Tables-to-divs regression in Custom Tools

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      custom-tools-plugin-0.8

      Description

      plugins.csvFreestyle project Build Environment settings are not being saved

      Modification on currently existing configuration causes all settings to be removed.

        Attachments

          Activity

          bloodrxt Paulina created issue -
          bloodrxt Paulina made changes -
          Field Original Value New Value
          Component/s freestyle-multibranch-plugin [ 20021 ]
          Component/s pipeline [ 21692 ]
          Component/s configuration-as-code-plugin [ 23170 ]
          bloodrxt Paulina made changes -
          Labels config.xml configuration-problem jenkins config.xml configuration configuration-problem jenkins
          bloodrxt Paulina made changes -
          Component/s freestyle-multibranch-plugin [ 20021 ]
          bloodrxt Paulina made changes -
          Component/s build-environment-plugin [ 17667 ]
          bloodrxt Paulina made changes -
          Component/s build-environment-plugin [ 17667 ]
          theli Vyacheslav Bogachenkov added a comment -

          I have the same problem

          I can't save the jobs and scripts bodies

          jenkins 2.263.x LTS + Managed Scripts 1.5.3

          downgrade managed scripts plugin to 1.4 helped me

           

           

           

          oleg_nenashev Oleg Nenashev made changes -
          Labels config.xml configuration configuration-problem jenkins config.xml configuration configuration-problem jenkins tables-to-divs-regression
          oleg_nenashev Oleg Nenashev made changes -
          Component/s core [ 15593 ]
          oleg_nenashev Oleg Nenashev added a comment -

          I'd guess this is a tables-to-divs related regression, caused by one of the plugins. Custom Tools plugin uses the table layout in the wrapper: https://github.com/jenkinsci/custom-tools-plugin/blob/9dffb2043d6fa3a356015bfb2e8f9edebbf0a83f/src/main/resources/com/cloudbees/jenkins/plugins/customtools/CustomToolInstallWrapper/config.jelly . It is likely to be the root cause

           

          Vyacheslav Bogachenkov your problem is different AFAICT. https://github.com/jenkinsci/managed-scripts-plugin/pull/13 changes the layout, likely it is a culprit. Please contact the plugin maintainers

          oleg_nenashev Oleg Nenashev made changes -
          Component/s customtools-plugin [ 16520 ]
          Component/s core [ 15593 ]
          Component/s pipeline [ 21692 ]
          bloodrxt Paulina added a comment - - edited

          Hi Oleg Nenashev, I've disabled Custom Tools plugin, restarted Jenkins and the issue is the same

          oleg_nenashev Oleg Nenashev added a comment -

          Bad luck. Other plugins do not seem to be impacted from what I can tell. Maybe a collateral damage from something else.

          Do you see any warnings in system log or the web browser developer console when applying the config?

          bloodrxt Paulina added a comment -

          Hey Oleg Nenashev, no errors, when I click apply it says "Saved" on top bar but when you go back to config it still not applied.

          No warnings in system log for the config im testing on.

           

          bloodrxt Paulina made changes -
          Labels config.xml configuration configuration-problem jenkins tables-to-divs-regression build-wrapper config.xml configuration configuration-problem jenkins tables-to-divs-regression
          bloodrxt Paulina added a comment -

          any news on this, upgrade to 2.278 and 2.279 still not fixing the issue

           

          timja Tim Jacomb added a comment -

          Paulina see https://issues.jenkins.io/browse/JENKINS-64072

          each case is different and needs a full plugin list to reproduce, normally caused by old plugins.

          bloodrxt Paulina made changes -
          Attachment plugins.csv [ 54024 ]
          bloodrxt Paulina made changes -
          Description Freestyle project Build Environment settings are not being saved

          Modification on currently existing configuration causes all settings to be removed.

          !image-2021-01-28-21-27-39-208.png|width=696,height=146!
          [^plugins.csv]Freestyle project Build Environment settings are not being saved

          Modification on currently existing configuration causes all settings to be removed.

          !image-2021-01-28-21-27-39-208.png|width=696,height=146!
          bloodrxt Paulina added a comment -

          added list of installed plugins

           

          oleg_nenashev Oleg Nenashev made changes -
          Released As custom-tools-plugin-0.8
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          bloodrxt Paulina added a comment -

          I've installed custom tools plugin 0.8 still the same issue.

          Build environment settings not saving

          bloodrxt Paulina made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          oleg_nenashev Oleg Nenashev added a comment -

          It works on my machine. Maybe there is another affected plugin breaking the layout

          basil Basil Crow added a comment -

          Maybe there is another affected plugin breaking the layout

          I took a look at the attached plugins.csv and indeed there is another plugin breaking the layout: Team Foundation Server 5.157.1. Team Foundation Server is known to be incompatible with the Configuration Form Modernization project (see JENKINS-64241). Team Foundation Server has also been suspended due to licensing issues and is not available in new installations (see INFRA-2751). The recommendation is to disable or remove Team Foundation Server.

          Paulina, can you please confirm that disabling or removing Team Foundation Server resolves your problem? If so, we can close this bug to cover Custom Tools and leave JENKINS-64241 open to cover Team Foundation Server.

          icoulter Iain Coulter made changes -
          Attachment jenkins_plugins.txt [ 54308 ]
          icoulter Iain Coulter added a comment -

          Have been experiencing exact same issue, posted my list of plugins "jenkins_plugins.txt" in hope someone can see out of these if there is another plugin at fault.   I have updated custom tools to 0.8  and don't have Team Foundation Server mentioned above

          bloodrxt Paulina added a comment -

          Updating all plugins, jenkins version and remove of TFS plugin resolved issue

          david_hertz David added a comment -

          The is a huge problem. The issued seems to related only to Maven projects.
          I do not have the TFS plugin.

          basil Basil Crow made changes -
          Labels build-wrapper config.xml configuration configuration-problem jenkins tables-to-divs-regression tables-to-divs-regression
          basil Basil Crow made changes -
          Summary Build environment on project configuration is not saving Tables-to-divs regression in Custom Tools
          basil Basil Crow added a comment -

          Updating all plugins, jenkins version and remove of TFS plugin resolved issue

          Thanks for confirming. Let's keep this bug focused specifically on the problem with Custom Tools and leave JENKINS-64241 open to cover Team Foundation Server specifically. Since the problem with Custom Tools has been fixed, I am marking this Jira issue as resolved.

          Iain Coulter and David, please file a new Jira issue with the tables-to-divs-regression label to cover any issues you are facing, following the instructions on this page to narrow down the problem.

          basil Basil Crow made changes -
          Resolution Fixed [ 1 ]
          Status Reopened [ 4 ] Resolved [ 5 ]

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            bloodrxt Paulina
            Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: