Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64792

Azure VM Agents plugin can sometime provision twice as many agents as configured

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: _unsorted
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.253
      Azure VM Agents 1.5.0
    • Similar Issues:

      Description

      The Jenkins plugin Azure VM Agents can sometime provision twice as many agents as configured for. The Jenkins log had those entries:

      2021-02-01 15:31:58.647+0000 [id=58] INFO c.m.azure.vmagent.AzureVMCloud#provision: AzureVMCloud: provision: start for label TestAgent&&Windows workLoad 97
      2021-02-01 15:32:00.132+0000 [id=58] INFO c.m.azure.vmagent.AzureVMCloud#provision: AzureVMCloud: provision: checking for node reuse options
      2021-02-01 15:32:00.133+0000 [id=58] INFO c.m.azure.vmagent.AzureVMCloud#provision: Able to create new nodes, but can only create 25 (desired 97)
      2021-02-01 15:32:00.142+0000 [id=58] INFO c.m.azure.vmagent.AzureVMCloud#provision: AzureVMCloud: provision: asynchronous provision finished, returning 25 planned node(s)
      ...
      2021-02-01 15:32:08.647+0000 [id=52] INFO c.m.azure.vmagent.AzureVMCloud#provision: AzureVMCloud: provision: start for label TestAgent&&Windows workLoad 72
      2021-02-01 15:32:10.035+0000 [id=52] INFO c.m.azure.vmagent.AzureVMCloud#provision: AzureVMCloud: provision: checking for node reuse options
      2021-02-01 15:32:10.035+0000 [id=52] INFO c.m.azure.vmagent.AzureVMCloud#provision: Able to create new nodes, but can only create 25 (desired 72)
      2021-02-01 15:32:10.037+0000 [id=52] INFO c.m.azure.vmagent.AzureVMCloud#provision: AzureVMCloud: provision: asynchronous provision finished, returning 25 planned node(s)
      

      The second time, it should have logged entries like the ones it did later:

      2021-02-01 15:32:18.648+0000 [id=55] INFO c.m.azure.vmagent.AzureVMCloud#provision: AzureVMCloud: provision: start for label TestAgent&&Windows workLoad 47
      2021-02-01 15:32:18.648+0000 [id=55] INFO c.m.azure.vmagent.AzureVMCloud#provision: AzureVMCloud: provision: checking for node reuse options
      2021-02-01 15:32:18.648+0000 [id=55] INFO c.m.azure.vmagent.AzureVMCloud#provision: Not able to create any new nodes, at or above maximum VM count of 25
      

      The root cause is probably a race condition.

        Attachments

          Activity

          timja Tim Jacomb added a comment -

          All issues have been transferred to GitHub.

          See https://github.com/jenkinsci/azure-vm-agents-plugin/issues

          Search the issue title to find it.

          (This is a bulk comment and can't link to the specific issue)


            People

            Assignee:
            azure_devops Azure DevOps
            Reporter:
            georges474 Georges Zwingelstein
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: