Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64887

ansibleLint parser does not support output of v4 or newer

    XMLWordPrintable

Details

    Description

      The warnings plugin does not read the output of ansible -p anymore.
      I see the code has not been updated since 2019, so I guess v4+ is not supported.
      v5 just got released as well.

      Attachments

        Issue Links

          Activity

            aairey Andy Airey created issue -
            drulli Ulli Hafner made changes -
            Field Original Value New Value
            Labels help-wanted
            drulli Ulli Hafner made changes -
            Labels help-wanted help-wanted newbie-friendly
            drulli Ulli Hafner made changes -
            Assignee Ulli Hafner [ drulli ]
            drulli Ulli Hafner made changes -
            Summary ansibleLint can no longer parse issues ansibleLint parser does not support output> v4 can no longer parse issues
            drulli Ulli Hafner made changes -
            Summary ansibleLint parser does not support output> v4 can no longer parse issues ansibleLint parser does not support output of v4 or newer
            drulli Ulli Hafner made changes -
            Link This issue duplicates JENKINS-65282 [ JENKINS-65282 ]
            drulli Ulli Hafner made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
            drulli Ulli Hafner made changes -
            Released As https://github.com/jenkinsci/warnings-ng-plugin/releases/tag/v9.0.0
            Status Fixed but Unreleased [ 10203 ] Resolved [ 5 ]

            People

              Unassigned Unassigned
              aairey Andy Airey
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: