Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-64907

master ... slave ... come on folks

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I know the term master is not solely associated with slavery. I think git went overboard in removing that term. But, Jenkins uses both 'master' and 'slave'! There's no way miss the referenced here. There are so many slavery-neutral terms to use. Let's pick less colorful; less gratuitously insensitive terminology.

        Attachments

          Activity

          sbroshar steve created issue -
          ianw Ian Williams added a comment -

          steve, Mark Waite provided a most considered response to your remarks on JENKINS-64834 - "Buttons are too big". I will endeavor to answer this issue similarly.

          I agree the term master is widely used without explicit contextual reference to slavery or subjugation; master recording and chess master come to mind. However, within the Jenkins context, it clearly occurred in the context-pairing master <-> slave.

          Respectfully, I would point out the subject of your issue has been extensively discussed within the Jenkins Community and actions taken to address the matter.

          While your Description does not suggest a remedy, some research may have lead you to discover this 2016 blog post On Jenkins Terminology Updates specifically relating to actions to deprecate and remove the term "slave", replacing it with the term "agent". Further actions were to come for other terms, including "master". Almost a year ago, Alex Earl initiated this thread to act on the word "master". resulting in a consensus vote conducted by Mark Waite and a decision to switch to the term "controller".

           It takes time and effort to remediate such extensive and embedded implementations. I'm sure the Jenkins Community would appreciate any contributions in the form of pull requests to mitigate any occurrences you may find and wish to see addressed.

          slide_o_mix Alex Earl added a comment -

          Yes, this is something the project is working on, it can't be done overnight, but is a work in progress. The "easy" changes are changes in documentation, website, strings, etc. The difficult ones are the code usages, e.g., "MasterToSlaveCallable" which we need to figure out how to migrate without breaking compatibility. I'm going to close this out as the issue is being addressed.

          slide_o_mix Alex Earl made changes -
          Field Original Value New Value
          Assignee 42Crunch APISecurity [ 42crunch ]
          Resolution Duplicate [ 3 ]
          Status Open [ 1 ] Closed [ 6 ]
          sbroshar steve added a comment -

          Thank you Alex for a thoughtful and professional response. Glad to hear the issue is being taken seriously. 

          Ian: I find your response to be mostly reasonable, but has off putting statements that seem to imply I should know everything the community does before logging an issue. That mindset seems to pervade the Jenkins community. Exclusive; not inclusive. Leaves bad taste in my mouth. And, you wonder what I suggest as a remedy? Thought that was obvious. Use different terms; ones that don't invoke slavery ... or other offensive words.

          ianw Ian Williams added a comment -

          steve , no one can be expected to know everything that goes on about everything, or anything.

          However, when you "Create" a new issue, there is a warning that appears, "Please read our Jira guidelines before creating an issue." which does offer some suggestions before creating a JIRA. It would seem that you chose to ignore those constructive suggestions, at least according to your remarks in JENKINS-64834,

          "First off this tracking system for tracking sucks. What's up with all the 'read this' in red BS? and how the F am I supposed to know what component? "  (talk about leaving a bad taste ...)

          When creating an issue, after entering a "Summary", JIRA also attempts to search for similar issues to prevent duplicates and provide a reference (Any results will often point you to earlier issue reports if it’s really a bug) . The summary you entered ("master ... slave ... come on folks") produces a limited (poor) match of top 5 issues.

          Searching "master slave terminology" indeed returns the latest EPIC JENKINS-65398 Terminology update for master, whitelist, blacklist, and JENKINS-62709 Remove remaining usages of "slave" terminology, which has a link to the original JENKINS-31095 2.0: Jenkins terminology sweep, which dates back to 2015.

          If you do indeed find any more offensive terminology, I would suggest the best thing to do is to create an issue and link it to either JENKINS-31095 or JENKINS-65398. You are also free to submit a PR with the corrections as well.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            sbroshar steve
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: