Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65318

Unable to access mirroring url while installing jenkins plug-ins for Version 1.277.1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: core
    • Labels:
    • Environment:
      Development
    • Similar Issues:

      Description

      Hi Team,

      We are installing Jenkins version 2.277.1 on windows server 2019.

      But installation failed during Suggested jenkins plug-in installation. After checking, it seems that mirroring URL is not accessible from instance. Same happening while downloading war file.

      Mirroring URL= https://mirrors.tuna.tsinghua.edu.cn

      This is blocker for us. How to resolve this issue?

      Please help. Thanks in advance.

      Regards,

      Bhakti

       

       

        Attachments

          Activity

          olblak Olivier Vernin added a comment -

          Hi Bhakti Joshi ,

          In case it helps you, we have a monitoring dashboard that tells you the third mirrors response time.

          It's a good indicator if a specific mirror is getting overloaded or just down

          -> https://jenkins.datadoghq.com/dashboard/28d-cyb-vin/mirror-response-time

          bhaktij Bhakti Joshi added a comment - - edited

          Hi All,

           

          Thanks for quick reply. 

          I am able to open " https://updates.jenkins.io/latest/git-client.hpi?mirrorlist" link and its confirm that nearest mirror is China. While browsing the URL, hpi file not get downloaded. So, it seems that I need to coordinate with our network team to verify firewall settings and need to allow this. 

          Again thanks for your time. 

           

           

          markewaite Mark Waite added a comment -

          To answer the specific question from Oleg, the closest geographic mirror is as shown by https://updates.jenkins.io/latest/git-client.hpi?mirrorlist . I suspect that the Chinese mirror is closer to the user than either of the mirrors in Japan.

          Bhakti Joshi can you open https://updates.jenkins.io/latest/git-client.hpi?mirrorlist and confirm that your nearest mirror is in China and that if you click the link from your web browser, it does not download the HPI file? If that's the case, you'll likely need to negotiate an exception to your company filtering strategy so that you're allowed to retrieve files from that mirror.

          markewaite Mark Waite added a comment -

          I suspect the issue is at the user site, not at the mirror site in China. Based on measurements from my location in Colorado, USA, the mirror site in China is responding with typical speeds:

          Likewise the performance for the last week has been reasonable:

          Some companies may block access to locations in China. In that case, they would need to download plugins individually from an alternate site (like one of the mirrors in Japan or in Europe).

          danielbeck Daniel Beck added a comment -

          Works for me.

          outside China

          Where are you getting that from?

          Is this really worth pinging four people over, including one innocent bystander?

          oleg_nenashev Oleg Nenashev added a comment -

          CC Olivier Vernin Tim Jaacks Daniel Beck Mark Waite. Looks like an infra issue. Is the Chinese mirror supposed to be accessible from outside China?


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            bhaktij Bhakti Joshi
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: