Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65422

Pipeline Maven Integration fails to publish spotbugs reports

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Using plugin version 3.10, I'm utilizing withMaven in a pipeline as follows:

      stage('Build') {
          withMaven {
              def args
              if (config.mavenArgs) {
                  // use config.mavenArgs, if supplied
                  args = config.mavenArgs
              } else {
                  // default args
                  args = 'clean install'
              }
              sh "./mvnw ${args}"
          }
          // withMaven will utilize maven wrapper and discover the generated Maven artifacts, JUnit Surefire & FailSafe reports and FindBugs reports
      }
      
      

      I have version 9.0.1 of Warnings Next Generation Plugin installed.

      Unfortunately, during the build, I get these messages in console output:

      [withMaven] Jenkins FindBugs Plugin not found, don't display com.github.spotbugs:spotbugs-maven-plugin:spotbugs results in pipeline screen.

      There are plenty of spotbugs XML files in the project, e.g.:

      $ find . -name '*spot*' | grep common
      ./common/web/target/spotbugsXml.xml
      ./common/web/target/site/spotbugs.xml
      ./common/utils/target/spotbugsXml.xml
      ./common/utils/target/site/spotbugs.xml
      ./common/testutils/target/spotbugsXml.xml
      ./common/testutils/target/site/spotbugs.xml
      ./acorn/common/target/spotbugsXml.xml
      ./acorn/common/target/site/spotbugs.xml
      ./common-rest/target/spotbugsXml.xml
      ./common-rest/target/site/spotbugs.xml

      Jenkins version is 2.289. Any help or advice is appreciated.

        Attachments

          Issue Links

            Activity

            corporate_gadfly Corporate created issue -
            corporate_gadfly Corporate made changes -
            Field Original Value New Value
            Description Using plugin version 3.10, I'm utilizing {{withMaven}} in a pipeline as follows:
            {code:java}
            stage('Build') {
                withMaven {
                    def args
                    if (config.mavenArgs) {
                        // use config.mavenArgs, if supplied
                        args = config.mavenArgs
                    } else {
                        // default args
                        args = 'clean install'
                    }
                    sh "./mvnw ${args}"
                }
                // withMaven will utilize maven wrapper and discover the generated Maven artifacts, JUnit Surefire & FailSafe reports and FindBugs reports
            }

            {code}
            I have version 9.0.1 of Warnings Next Generation Plugin installed.

            Unfortunately, during the build, I get these messages in console output:
            {noformat}
            [withMaven] Jenkins FindBugs Plugin not found, don't display com.github.spotbugs:spotbugs-maven-plugin:spotbugs results in pipeline screen.{noformat}
            There are plenty of spotbugs XML files in the project, e.g.:
            {noformat}
            $ find . -name '*spot*' | grep common
            ./common/web/target/spotbugsXml.xml
            ./common/web/target/site/spotbugs.xml
            ./common/utils/target/spotbugsXml.xml
            ./common/utils/target/site/spotbugs.xml
            ./common/testutils/target/spotbugsXml.xml
            ./common/testutils/target/site/spotbugs.xml
            ./acorn/common/target/spotbugsXml.xml
            ./acorn/common/target/site/spotbugs.xml
            ./common-rest/target/spotbugsXml.xml
            ./common-rest/target/site/spotbugs.xml{noformat}
            Any help or advice is appreciated.
            Using plugin version 3.10, I'm utilizing {{withMaven}} in a pipeline as follows:
            {code:java}
            stage('Build') {
                withMaven {
                    def args
                    if (config.mavenArgs) {
                        // use config.mavenArgs, if supplied
                        args = config.mavenArgs
                    } else {
                        // default args
                        args = 'clean install'
                    }
                    sh "./mvnw ${args}"
                }
                // withMaven will utilize maven wrapper and discover the generated Maven artifacts, JUnit Surefire & FailSafe reports and FindBugs reports
            }

            {code}
            I have version 9.0.1 of Warnings Next Generation Plugin installed.

            Unfortunately, during the build, I get these messages in console output:
            {noformat}
            [withMaven] Jenkins FindBugs Plugin not found, don't display com.github.spotbugs:spotbugs-maven-plugin:spotbugs results in pipeline screen.{noformat}
            There are plenty of spotbugs XML files in the project, e.g.:
            {noformat}
            $ find . -name '*spot*' | grep common
            ./common/web/target/spotbugsXml.xml
            ./common/web/target/site/spotbugs.xml
            ./common/utils/target/spotbugsXml.xml
            ./common/utils/target/site/spotbugs.xml
            ./common/testutils/target/spotbugsXml.xml
            ./common/testutils/target/site/spotbugs.xml
            ./acorn/common/target/spotbugsXml.xml
            ./acorn/common/target/site/spotbugs.xml
            ./common-rest/target/spotbugsXml.xml
            ./common-rest/target/site/spotbugs.xml{noformat}
            Jenkins version is 2.289. Any help or advice is appreciated.
            bguerin Benoit added a comment -

            Hello,

            pipeline-maven-plugin is, for now, integrated with the old and deprecated findbugs-plugin.
            What you want (and we need to do) is integrate it with the warnings-ng-plugin.
            I want too also, it is on my todo list and tracked here : https://issues.jenkins.io/browse/JENKINS-57427

            So I am closing this issue, as a duplicate of JENKINS-57427
             

            bguerin Benoit made changes -
            Link This issue duplicates JENKINS-57427 [ JENKINS-57427 ]
            bguerin Benoit made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              corporate_gadfly Corporate
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: