Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-65684

Job configure - properties on save

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      When using the Web UI job Configure page the existing project definition looses all child elements for this xpath when Save or Apply button is clicked.

      /flow-definition/properties/*

       The project is a pipeline job created some months ago. With parametrised properties added.

      For example this XML

       <properties>
       <hudson.plugins.jira.JiraProjectProperty plugin="jira@3.1.1"/>
       <org.jenkinsci.plugins.workflow.job.properties.DisableConcurrentBuildsJobProperty/>
       <org.jenkinsci.plugins.workflow.job.properties.DisableResumeJobProperty/>
       <com.sonyericsson.rebuild.RebuildSettings plugin="rebuild@1.31">
       <autoRebuild>false</autoRebuild>
       <rebuildDisabled>false</rebuildDisabled>
       </com.sonyericsson.rebuild.RebuildSettings>
       <hudson.model.ParametersDefinitionProperty>
       <parameterDefinitions>
       <hudson.model.StringParameterDefinition>
       <name>JFR_PROFILE</name>
       <description>attach a jfr profile</description>
       <defaultValue></defaultValue>
       <trim>false</trim>
       </hudson.model.StringParameterDefinition>
       </parameterDefinitions>
       </hudson.model.ParametersDefinitionProperty>
       <hudson.plugins.throttleconcurrents.ThrottleJobProperty plugin="throttle-concurrents@2.0.3">
       <maxConcurrentPerNode>0</maxConcurrentPerNode>
       <maxConcurrentTotal>1</maxConcurrentTotal>
       <categories class="java.util.concurrent.CopyOnWriteArrayList"/>
       <throttleEnabled>true</throttleEnabled>
       <throttleOption>project</throttleOption>
       <limitOneJobWithMatchingParams>false</limitOneJobWithMatchingParams>
       <paramsToUseForLimit></paramsToUseForLimit>
       <configVersion>1</configVersion>
       </hudson.plugins.throttleconcurrents.ThrottleJobProperty>
       </properties> 

      becomes

      <properties/>

      Checking the Jenkins log I don't find any exceptions. Testing with Chrome browser the same issue happens. A colleague has experienced the same problem also with Firefox.

       This issue first occurred after upgrading to 2.277.2 Jenkins from an older version. Since then steps to clear out unused plugins, upgrade plugins, jenkins, then plugins again. This did not solve the issue.

      Checking the HTTP POST request when the browser Save button is clicked shows the request to contain the parameters. See the attachment.

       

      Files have been attached with details of plugins installed. Plus the system info.

       on the server

      Jenkins 2.277.4
      $ uname -a
      Linux somewhere.com 4.18.0-240.el8.x86_64 #1 SMP Wed Sep 23 05:13:10 EDT 2020 x86_64 x86_64 x86_64 GNU/Linux

      on the client

      $ firefox -version
      Mozilla Firefox 88.0.1
      $ uname -a
      Linux burtha-f33 5.8.15-301.fc33.x86_64 #1 SMP Thu Oct 15 16:58:06 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
      $

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              whitingjr Jeremy Whiting
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: