Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-66100

Images for "Github Repository" and "New View" are failing to load with 403 (unauthorized) error for admin users.

    XMLWordPrintable

    Details

    • Similar Issues:
    • Released As:
      github-branch-source-2.11.2, cloudbees-folder-6.16

      Description

      After upgrading Matrix Authorization Strategy Plugin from v2.6.5 to v2.6.7, we noticed that some images on the home page were failing to load (Broken image logo showing up). Looking into the "inspecting" those broken images revealed that they were being blocked with "Unauthorized" error even for the users with full access.

        Attachments

          Activity

          bbhagat4 bhavesh created issue -
          bbhagat4 bhavesh made changes -
          Field Original Value New Value
          Description After upgrading Matrix Authorization Strategy Plugin from v2.6.5 to v2.6.7, we noticed that some images on the home page were failing to load (Broken image logo showing up). Looking into the "inspecting" those broken images revealed that they were being blocked with "Unauthorized" error even for the users with full access.
          danielbeck Daniel Beck added a comment -

          There's nothing in 2.6.6 or 2.6.7 that would cause this. Please provide more information. In particular, versions of Jenkins before and after the update, as well as whether you have configured a Jenkins root URL and whether it's different than the URL you use to access Jenkins. Also, are you using a reverse proxy?

          bbhagat4 bhavesh added a comment -

          Hi Daniel,

          Please find the requested details below:

          1) Versions of Jenkins:

          Before: 2.263.1-lts

          After: 2.277.4-lts

          2) Whether you have configured a Jenkins root URL: We have configured the "Jenkins URL" as https://jenkins.apps.<companyName>.com/ But we have not configured "Resource Root URL".

          3) Are you using a reverse proxy? - Yes

           

          Please let me know if you have any other questions.

           

          Thank you!

          • Bhavesh.
          danielbeck Daniel Beck added a comment -

          Please check to make sure the resource requests are towards the same host and protocol as you are accessing Jenkins at. Compare these requests with others that succeed.

          Given how the "Create View" icon computes its URL, it's likely a side effect of a bad Jenkins URL or reverse proxy configuration.

          markewaite Mark Waite made changes -
          Attachment github-broken-icon.png [ 55179 ]
          markewaite Mark Waite added a comment -

          Does the broken GitHub icon look like this (using an example from ci.jenkins.io):

          If so, then I believe that is a bug in the GitHub Branch Source plugin.

          danielbeck Daniel Beck added a comment -

          Weird that "New View" is affected too though?

          markewaite Mark Waite added a comment -

          Yes, I agree that it is surprising that it also affects "New View". I don't see any broken icons when I'm using "New View". The case that I'm describing may not be the same case as is described by bhavesh

          bbhagat4 bhavesh added a comment -

          Hi Mark,
           
          Yes, that was one of the icons broken for me. Once I rolled back the plugin to the previous version, it started working again. That said, I don't think it is a reverse proxy configuration issue.

          markewaite Mark Waite added a comment -

          I agree that the GitHub Branch Source broken icon is not related to a reverse proxy, since I see the same failure on my Docker image that does not use a reverse proxy. I recommend that we rephrase this issue report to note that the GitHub Branch Source image icon is broken.

          I'm not able to duplicate the "New View" broken icon. Can you provide precise steps so that another person can duplicate the problem? Once you've described those steps, we can confirm that others see the same issue and can then have you submit a new issue for the plugin that implements "New View".

          bbhagat4 bhavesh added a comment -

          Hi Mark,

          I'll try to recreate this issue tonight and take a screen shot. But, I am OK with rephrasing the issue.

          Thank you!

          • Bhavesh.
          markewaite Mark Waite made changes -
          Component/s github-branch-source-plugin [ 20858 ]
          Component/s matrix-auth-plugin [ 18131 ]
          markewaite Mark Waite made changes -
          Description After upgrading Matrix Authorization Strategy Plugin from v2.6.5 to v2.6.7, we noticed that some images on the home page were failing to load (Broken image logo showing up). Looking into the "inspecting" those broken images revealed that they were being blocked with "Unauthorized" error even for the users with full access. After upgrading Matrix Authorization Strategy Plugin from v2.6.5 to v2.6.7, we noticed that some images on the home page were failing to load (Broken image logo showing up). Looking into the "inspecting" those broken images revealed that they were being blocked with "Unauthorized" error even for the users with full access.

           !github-broken-icon.png|thumbnail!
          markewaite Mark Waite made changes -
          Description After upgrading Matrix Authorization Strategy Plugin from v2.6.5 to v2.6.7, we noticed that some images on the home page were failing to load (Broken image logo showing up). Looking into the "inspecting" those broken images revealed that they were being blocked with "Unauthorized" error even for the users with full access.

           !github-broken-icon.png|thumbnail!
          After upgrading Matrix Authorization Strategy Plugin from v2.6.5 to v2.6.7, we noticed that some images on the home page were failing to load (Broken image logo showing up). Looking into the "inspecting" those broken images revealed that they were being blocked with "Unauthorized" error even for the users with full access.

           !github-broken-icon.png|!
          markewaite Mark Waite made changes -
          Description After upgrading Matrix Authorization Strategy Plugin from v2.6.5 to v2.6.7, we noticed that some images on the home page were failing to load (Broken image logo showing up). Looking into the "inspecting" those broken images revealed that they were being blocked with "Unauthorized" error even for the users with full access.

           !github-broken-icon.png|!
          After upgrading Matrix Authorization Strategy Plugin from v2.6.5 to v2.6.7, we noticed that some images on the home page were failing to load (Broken image logo showing up). Looking into the "inspecting" those broken images revealed that they were being blocked with "Unauthorized" error even for the users with full access.

          An example from ci.jenkins.io of the broken icon for the GitHub branch source.

           !github-broken-icon.png|!
          danielbeck Daniel Beck added a comment -

          Once I rolled back the plugin to the previous version, it started working again.

          To clarify, all other versions of components remained the same, you just downgraded matrix-auth from 2.6.6/2.6.7 to 2.6.5, and it worked again?

          Mark Waite Why rewrite the issue before we've identified what's even likely the culprit here?

          markewaite Mark Waite made changes -
          Description After upgrading Matrix Authorization Strategy Plugin from v2.6.5 to v2.6.7, we noticed that some images on the home page were failing to load (Broken image logo showing up). Looking into the "inspecting" those broken images revealed that they were being blocked with "Unauthorized" error even for the users with full access.

          An example from ci.jenkins.io of the broken icon for the GitHub branch source.

           !github-broken-icon.png|!
          After upgrading Matrix Authorization Strategy Plugin from v2.6.5 to v2.6.7, we noticed that some images on the home page were failing to load (Broken image logo showing up). Looking into the "inspecting" those broken images revealed that they were being blocked with "Unauthorized" error even for the users with full access.

          markewaite Mark Waite added a comment -

          Daniel Beck I was trying to add further clarity to the issue description based on the confirmation from bhavesh that the broken GitHub branch source image screenshot matched his experience. I've removed the text that I added to the description. I assumed that my addition of text to the description was OK based on bhavesh saying,

          I am OK with rephrasing the issue

          .

          I'll let you or bhavesh decide if it needs to be reassigned to the matrix-auth plugin.

          timja Tim Jacomb made changes -
          Remote Link This issue links to "github-branch-source-plugin/pull/440 (Web Link)" [ 26832 ]
          timja Tim Jacomb made changes -
          Assignee Daniel Beck [ danielbeck ]
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
          timja Tim Jacomb made changes -
          Resolution Fixed [ 1 ]
          Status Fixed but Unreleased [ 10203 ] Reopened [ 4 ]
          timja Tim Jacomb added a comment -
          timja Tim Jacomb made changes -
          Component/s cloudbees-folder-plugin [ 18137 ]
          danielbeck Daniel Beck added a comment -

          Tim Jacomb Why would that cause a 403 error?

          timja Tim Jacomb added a comment -

          The url was wrong, must’ve been routed to something that ended up getting a 403 instead of a 404

          bitwiseman Liam Newman made changes -
          Released As github-branch-source-2.11.2, cloudbees-folder-6.16
          Resolution Fixed [ 1 ]
          Status Reopened [ 4 ] Resolved [ 5 ]
          bitwiseman Liam Newman added a comment -

          github-branch-source-2.11.2, cloudbees-folder 6.16 combine to fix this.

          markewaite Mark Waite added a comment -

          Confirmed that GitHub branch source plugin 2.11.2 fixes the issue that I'd seen. Thanks!


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            bbhagat4 bhavesh
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: