Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-66184

Multibranch Pipeline marks a branch job disabled for an still existing branch

    XMLWordPrintable

Details

    Description

      Hello,

       

      we have a mutlibranch pipeline connected to Github Enterprise repo, that has a filter to get one main branch and pull requests to create jobs. The branches have a configured Jenkinsfile with a pipeline included. It works for a while very well. Jenkins create and triggers jobs based on github event.

      Today it stopped to work as expected. No config on the multibranch pipeline.

      Jenkins multibranch pipeline marked the branch as disabled (what usually happen when a branch has been deleted). The config shows <disabled>true</disabled>
      But I checked the branch still exists.

      After a rescan the branch is still disabled. I do not have any chance to get it runing again.

       

      The scan log does not show any action (reenable or something....

      Examining

      <repo>

      Checking branches...

      Getting remote branches...

      Checking branch

      <branchname>

      Getting remote pull requests...

       

       

       

       

       

      Attachments

        Activity

          jimjaeger jim jaeger created issue -
          jimjaeger jim jaeger made changes -
          Field Original Value New Value
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
          jimjaeger jim jaeger made changes -
          Status Fixed but Unreleased [ 10203 ] Closed [ 6 ]

          People

            igalg Igal Gluh
            jimjaeger jim jaeger
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: