Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-66242

How to deploy the .net windows service (Test.exe) in windows server using the Jenkins Pipeline

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: pipeline
    • Labels:
      None
    • Similar Issues:

      Description

      Hi ,

      Looking for the windows services deployment .net windows service (Test.exe) in windows server using the Jenkins Pipeline.

       

      Thanks,

      Deepa

        Attachments

          Activity

          deepa_resideo Deepa added a comment -

          Daniel Beck - Could you please check here and help me out

          kon Kalle Niemitalo added a comment - - edited

          AFAIK, Jenkins does not provide any pipeline steps for deploying a service on Windows. You should find out how the service was designed to be installed without Jenkins (for example, does it support installutil.exe?), and then use a bat or powershell or pwsh step in the pipeline to run the same commands. This will require an administrative user account in the computer to which you deploy the service. If you aren’t running a Jenkins agent on the target computer itself, then you’ll also need a way to run commands remotely (e.g. an SSH server or PowerShell remoting) and credentials for that.

          (sc.exe create does support creating a service on a remote computer, but deploying a service also requires copying the files and usually creating Registry keys and values to register event sources and configure the service. If the service software already includes an installation mechanism, I don’t think it makes sense to reimplement that as a command batch that runs sc.exe and reg.exe.)

          This kind of question would be better asked on the mailing list because you are not requesting a change.

          deepa_resideo Deepa added a comment -

          Kalle Niemitalo - Thank you let me check and get back to you.

          deepa_resideo Deepa added a comment -

          Kalle Niemitalo  - Can you share the mailing list to proceed further communications.

          danielbeck Daniel Beck added a comment -

          Please don't use the issue tracker to ask questions.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            deepa_resideo Deepa
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: