Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67198

Jenkins 2.320 Job configuration dialog width too small

    XMLWordPrintable

Details

    • 2.331

    Description

      The new job configuration dialog (introduced by PR #5842 width is too small. On a 27'' Monitor it just fills 1/4 of the screen. Additionally, the tab navigation (and the background) is using 1/2 of the screen which looks somewhat strange. It makes sense to restore the old size in order to reduce the scrolling amount required to see all details.

      Attachments

        Issue Links

          Activity

            drulli Ulli Hafner created issue -
            drulli Ulli Hafner made changes -
            Field Original Value New Value
            Summary Job configuration dialog too small Job configuration dialog width too small
            drulli Ulli Hafner made changes -
            Description The new job configuration dialog (introduced by [PR #5842|https://github.com/jenkinsci/jenkins/pull/5842] is too small (width). On a 27'' Monitor it just fills 1/4 of the screen. Additionally, the tab navigation (and the background) is using 1/2 of the screen which looks somewhat strange. It makes sense to restore the old size in order to reduce the scrolling about required to see all details.


            The new job configuration dialog (introduced by [PR #5842|https://github.com/jenkinsci/jenkins/pull/5842] width is too small. On a 27'' Monitor it just fills 1/4 of the screen. Additionally, the tab navigation (and the background) is using 1/2 of the screen which looks somewhat strange. It makes sense to restore the old size in order to reduce the scrolling amount required to see all details.


            drulli Ulli Hafner made changes -
            Remote Link This issue links to "Caused by PR#5842 (Web Link)" [ 27237 ]
            danielbeck Daniel Beck made changes -
            Labels regression
            danielbeck Daniel Beck made changes -
            Priority Major [ 3 ] Critical [ 2 ]
            bcoveny Bruce Coveny made changes -
            Link This issue is duplicated by JENKINS-67257 [ JENKINS-67257 ]
            ianw Ian Williams made changes -
            Summary Job configuration dialog width too small Jenkins 3.220 Job configuration dialog width too small

            Same, refuse to install any new version until its fixed.

            nbl9999 Nathan Lindshield added a comment - Same, refuse to install any new version until its fixed.
            bcoveny Bruce Coveny made changes -
            Summary Jenkins 3.220 Job configuration dialog width too small Jenkins 2.320 Job configuration dialog width too small
            maxdegraaf Max de Graaf added a comment -

            Please get this fixed, its a nightmare working like this.

            maxdegraaf Max de Graaf added a comment - Please get this fixed, its a nightmare working like this.
            basil Basil Crow made changes -
            Link This issue is duplicated by JENKINS-67207 [ JENKINS-67207 ]
            maxdegraaf Max de Graaf added a comment -

            https://issues.jenkins.io/browse/JENKINS-67207 is set to RESOLVED. We are now running 2.324 and the " "Execute shell" still does not resize at all.

            maxdegraaf Max de Graaf added a comment - https://issues.jenkins.io/browse/JENKINS-67207  is set to RESOLVED. We are now running 2.324 and the " "Execute shell" still does not resize at all.
            ipi_kiiskinen Ipi Kiiskinen added a comment - - edited

            Please get this fixed. Would anyone know how should be the assignee?

            ipi_kiiskinen Ipi Kiiskinen added a comment - - edited Please get this fixed. Would anyone know how should be the assignee?
            danielbeck Daniel Beck added a comment -

            Other than the weird job config form with a separate frame, it even looks weird in the global config with the "Help make Jenkins better" option's label being longer than the available width.

            danielbeck Daniel Beck added a comment - Other than the weird job config form with a separate frame, it even looks weird in the global config with the "Help make Jenkins better" option's label being longer than the available width.
            janfaracik Jan Faracik made changes -
            Assignee Jan Faracik [ JIRAUSER136250 ]
            janfaracik Jan Faracik made changes -
            Attachment image-2021-12-18-19-49-01-875.png [ 56966 ]
            janfaracik Jan Faracik added a comment -

            Hey folk, 

            This will be updated as part of PR #5923(https://github.com/jenkinsci/jenkins/pull/5923), here's what the WIP PR looks like at 1920px wide. There'll also be another PR going up soon after 5923 to improve this page.

            As for 67207, I'll investigate it.

            Thanks for the feedback everyone,

            Jan

            janfaracik Jan Faracik added a comment - Hey folk,  This will be updated as part of PR #5923 ( https://github.com/jenkinsci/jenkins/pull/5923),  here's what the WIP PR looks like at 1920px wide. There'll also be another PR going up soon after 5923 to improve this page. As for 67207, I'll investigate it. Thanks for the feedback everyone, Jan
            drulli Ulli Hafner added a comment -

            Seems that in the new screenshot the forms still do not use the whole area of the tabs container? There is still empty gray area on the right. 

            drulli Ulli Hafner added a comment - Seems that in the new screenshot the forms still do not use the whole area of the tabs container? There is still empty gray area on the right. 
            igorhx Igor Hx added a comment - - edited

            Please fix this, because of this we're stuck at 2.317, as this is a showstopper.

             

            igorhx Igor Hx added a comment - - edited Please fix this, because of this we're stuck at 2.317, as this is a showstopper.  
            ianw Ian Williams added a comment -

            igorhx, how exactly is this a "showstopper"? It would seem to be that this is more of a minor UI annoyance. It does not appear to impede the input/modification of field data.

            While I respect drulli 's original classification and danielbeck 's reclassification, were I creating this issue, based on the Jenkins classification, I would have classified this as a "Minor" issue at best (at worst?).

            I also think the Field should be relabelled more appropriately as "Severity", given Jenkins own guidance,

            This is not how urgently you want it fixed.

            as that seems to more correctly reflect its intended and common use.

            ianw Ian Williams added a comment - igorhx , how exactly is this a "showstopper"? It would seem to be that this is more of a minor UI annoyance. It does not appear to impede the input/modification of field data. While I respect drulli 's original classification and danielbeck 's reclassification, were I creating this issue , based on the Jenkins classification , I would have classified this as a "Minor" issue at best (at worst?). I also think the Field should be relabelled more appropriately as "Severity", given Jenkins own guidance, This is not how urgently you want it fixed. as that seems to more correctly reflect its intended and common use.
            maxdegraaf Max de Graaf added a comment -

            We are running the version with this particular problem. We can't revert to an older version because of dependencies on plugins so we are stuck. If this should be classified as minor or critical I don't know. What i do know is the simple fact that we using the "|Execute shell Command" section a lot with a lots of scripting in there. Now with this annoying problem we copy the script into another editor, make the required changes and copy it back in the Jenkins UI. So i would not call it a showstopper, but for us its not a minor issue for sure.

            maxdegraaf Max de Graaf added a comment - We are running the version with this particular problem. We can't revert to an older version because of dependencies on plugins so we are stuck. If this should be classified as minor or critical I don't know. What i do know is the simple fact that we using the "|Execute shell Command" section a lot with a lots of scripting in there. Now with this annoying problem we copy the script into another editor, make the required changes and copy it back in the Jenkins UI. So i would not call it a showstopper, but for us its not a minor issue for sure.
            ianw Ian Williams added a comment -

            I'm just suggesting it's "Minor loss of function, or other problem where easy workaround is present." There appears to be no loss of functionality; horizontal scrolling or copy/pasting to an external editor is a trivial workaround, making it an "annoying problem", as you note.

            Reference: IEEE Std 1044-2009: IEEE Standard Classification for Software Anomalies - Annex A

            ianw Ian Williams added a comment - I'm just suggesting it's "Minor loss of function, or other problem where easy workaround is present." There appears to be no loss of functionality; horizontal scrolling or copy/pasting to an external editor is a trivial workaround, making it an "annoying problem", as you note. Reference: IEEE Std 1044-2009: IEEE Standard Classification for Software Anomalies - Annex A
            maxdegraaf Max de Graaf added a comment -

            I agree with you Ian. But keep in mind this particular problem has been reported as fixed several times already in previous versions.

            maxdegraaf Max de Graaf added a comment - I agree with you Ian. But keep in mind this particular problem has been reported as fixed several times already in previous versions.
            igorhx Igor Hx added a comment -

            I understand you guys, but from our customer point of view this is a serious issue - something what worked suddenly stopped working weeks ago and the fix is being postponed.

            Copying the contents to an external editor and then copying back it's indeed a workaround, but it's annoying.

            So we will stick with latest working version 2.317 and hopefully get a fix in near future...

            Have a nice holiday!

            igorhx Igor Hx added a comment - I understand you guys, but from our customer point of view this is a serious issue - something what worked suddenly stopped working weeks ago and the fix is being postponed. Copying the contents to an external editor and then copying back it's indeed a workaround, but it's annoying. So we will stick with latest working version 2.317 and hopefully get a fix in near future... Have a nice holiday!
            danielbeck Daniel Beck added a comment -

            2.317

            In that case you should probably install https://plugins.jenkins.io/remoting-security-workaround/ unless you fully trust all code you're building.

            danielbeck Daniel Beck added a comment - 2.317 In that case you should probably install https://plugins.jenkins.io/remoting-security-workaround/ unless you fully trust all code you're building.
            timja Tim Jacomb made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            timja Tim Jacomb made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            timja Tim Jacomb made changes -
            Remote Link This issue links to "Mostly fixed by https://github.com/jenkinsci/jenkins/pull/5923 (Web Link)" [ 27325 ]
            drulli Ulli Hafner added a comment - - edited

            timja: From my understanding PR#5923 did not fix the problem yet. In my review the sizes of the dialog and the tab did not match yet. 

            drulli Ulli Hafner added a comment - - edited timja : From my understanding PR#5923 did not fix the problem yet. In my review  the sizes of the dialog and the tab did not match yet. 
            timja Tim Jacomb added a comment -

            It makes it a lot better, (I added that in the links to).

            (The Jira ticket status here doesn't really make a lot of sense, it will be done in multiple pull requests with the main fix coming soon)

            timja Tim Jacomb added a comment - It makes it a lot better, (I added that in the links to). (The Jira ticket status here doesn't really make a lot of sense, it will be done in multiple pull requests with the main fix coming soon)
            markewaite Mark Waite made changes -
            Link This issue is duplicated by JENKINS-67499 [ JENKINS-67499 ]
            danielbeck Daniel Beck made changes -
            Remote Link This issue links to "PR#6172 (Web Link)" [ 27345 ]
            markewaite Mark Waite made changes -
            Released As 2.331
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Resolved [ 5 ]
            markewaite Mark Waite made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

            People

              janfaracik Jan Faracik
              drulli Ulli Hafner
              Votes:
              9 Vote for this issue
              Watchers:
              15 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: