Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67832

Manage nodes and clouds add "[offline]" text to offline agents in Jenkins 2.335

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Duplicate
    • core

    Description

      The "Manage nodes and clouds" page available from https://jenkins.example.com/jenkins/computer (as an example) displays text for some offline agents rather than displaying an image.

      In this example, all the agents visible in the list are offline, but some of them are showing the word "[offline]" (seem to be agents managed with ssh) while one of them (the inbound agent) shows the expected icon.

      Attachments

        Issue Links

          Activity

            markewaite Mark Waite created issue -

            Do you mind taking a look which icon and path it references to? I can imagine some changes to the Computer class in 6273 could have caused this, but I don't have an environment with ssh agents set up at the moment.

            notmyfault Alexander Brandes added a comment - Do you mind taking a look which icon and path it references to? I can imagine some changes to the Computer class in 6273 could have caused this, but I don't have an environment with ssh agents set up at the moment.
            markewaite Mark Waite made changes -
            Field Original Value New Value
            Attachment Screenshot 2022-02-17 080954.png [ 57278 ]
            markewaite Mark Waite added a comment - - edited

            I think it is "/icon-computer" with the alt text "[offline]", if I understand the output of "Inspect" correctly.

            P.S. thanks for the pointer to "Inspect". I'm not experienced with web development. Seeing those sorts of tools are a real help as I learn more.

            markewaite Mark Waite added a comment - - edited I think it is "/icon-computer" with the alt text " [offline] ", if I understand the output of "Inspect" correctly. P.S. thanks for the pointer to "Inspect". I'm not experienced with web development. Seeing those sorts of tools are a real help as I learn more.
            notmyfault Alexander Brandes added a comment - - edited

            P.S. thanks for the pointer to "Inspect". I'm not experienced with web development. Seeing those sorts of tools are a real help as I learn more.

            No problem, helps finding the cause of the missing icon a bit better : P
            The one in the cloudbees folder plugin was a bit harder to locate.

            Looks a bit like a duplicate of JENKINS-67828, no? At least the icon path is the same

            notmyfault Alexander Brandes added a comment - - edited P.S. thanks for the pointer to "Inspect". I'm not experienced with web development. Seeing those sorts of tools are a real help as I learn more. No problem, helps finding the cause of the missing icon a bit better : P The one in the cloudbees folder plugin was a bit harder to locate. Looks a bit like a duplicate of JENKINS-67828 , no? At least the icon path is the same
            markewaite Mark Waite made changes -
            Link This issue duplicates JENKINS-67828 [ JENKINS-67828 ]
            markewaite Mark Waite made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]
            markewaite Mark Waite added a comment -

            I've confirmed that this is resolved by https://github.com/jenkinsci/jenkins/pull/6282 that fixes JENKINS-67828

            markewaite Mark Waite added a comment - I've confirmed that this is resolved by https://github.com/jenkinsci/jenkins/pull/6282 that fixes JENKINS-67828
            danielbeck Daniel Beck made changes -
            Labels regression
            basil Basil Crow made changes -
            Link This issue is caused by JENKINS-68231 [ JENKINS-68231 ]

            People

              Unassigned Unassigned
              markewaite Mark Waite
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: