Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67877

Bitbucket organization folder not rendered correctly in 2.335 and 2.336

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • None
    • Jenkins 2.335 and 2.336
      cloudbees-bitbucket-branch-source:756.v081ee2205040
    • 757.vddedc5f2589a_

    Description

      The Bitbucket team / organization folders do not render correctly with Jenkins 2.335 and Jenkins 2.336. It looks like this:

      The inspect of the affected elements shows this:

      Attachments

        Issue Links

          Activity

            Someone on JENKINS-67823 commented:

            This is still an issue in 2.336 for Organization Folders configured for Bitbucket Team/Project.

            Had to roll back to 2.334. 

            Based on my findings, that doesn't work on 2.334 either:

            It appears that the bitbucket branch source plugin doesn't register the default icon properly in the first place, which now leads to the icon class being the icon source I guess?

            notmyfault Alexander Brandes added a comment - Someone on JENKINS-67823 commented: This is still an issue in 2.336 for Organization Folders configured for Bitbucket Team/Project. Had to roll back to 2.334.  Based on my findings, that doesn't work on 2.334 either: It appears that the bitbucket branch source plugin doesn't register the default icon properly in the first place, which now leads to the icon class being the icon source I guess?
            notmyfault Alexander Brandes added a comment - - edited

            Yeah, my previous comment outlines it well. The default bitbucket scm navigator icon is registered as "icon-bitbucket-scm-navigator" but referenced as "icon-bitbucket-scmnavigator", hence it isn't shown. I removed the regression label, because the same applies to older versions, like 2.319.3, as well:

            PR is up and linked above.

            notmyfault Alexander Brandes added a comment - - edited Yeah, my previous comment outlines it well. The default bitbucket scm navigator icon is registered as "icon-bitbucket-scm-navigator" but referenced as "icon-bitbucket-scmnavigator", hence it isn't shown. I removed the regression label, because the same applies to older versions, like 2.319.3, as well: PR is up and linked above.
            markewaite Mark Waite added a comment -

            Thanks notmyfault for noting that the issue is not a regression and for the pull request to fix the issue.  Much appreciated!

            markewaite Mark Waite added a comment - Thanks notmyfault  for noting that the issue is not a regression and for the pull request to fix the issue.  Much appreciated!
            markewaite Mark Waite added a comment -

            Thanks notmyfault! Released as 757.vddedc5f2589a_

            markewaite Mark Waite added a comment - Thanks notmyfault ! Released as 757.vddedc5f2589a_
            phbaer Philipp Baer added a comment -

            Still experiencing the issue with 2.337 and 757.vddedc5f2589a_ at least if a prefix is configured. Seems to be related to JENKINS-67869 which was fixed already.

            <img src="/jenkinshttps://[***masked***]/jenkins/custom-avatar-cache/b24e8b3a1e94bc5c71335bdda47a18d3.png?size=32x32" alt="Bitbucket Team/Project" tooltip="Bitbucket Team/Project" class="icon-lg" title="Bitbucket Team/Project">

            phbaer Philipp Baer added a comment - Still experiencing the issue with 2.337 and 757.vddedc5f2589a_ at least if a prefix is configured. Seems to be related to  JENKINS-67869 which was fixed already. <img src="/jenkinshttps:// [***masked***] /jenkins/custom-avatar-cache/b24e8b3a1e94bc5c71335bdda47a18d3.png?size=32x32" alt="Bitbucket Team/Project" tooltip="Bitbucket Team/Project" class="icon-lg" title="Bitbucket Team/Project">

            Same here. Issue does not seem fixed.

            cschoell Christof Schoell added a comment - Same here. Issue does not seem fixed.
            notmyfault Alexander Brandes added a comment - - edited

            That is a different issue tracked in JENKINS-67849
            This issue solely tracks the typo in the icon registry of the bitbucket branch source plugin.

            notmyfault Alexander Brandes added a comment - - edited That is a different issue tracked in JENKINS-67849 This issue solely tracks the typo in the icon registry of the bitbucket branch source plugin.

            I have the same issue when running jenkins in a tomcat (deployed as war) - no --prefix set but exactly this behaviour (2.338)

            cschoell Christof Schoell added a comment - I have the same issue when running jenkins in a tomcat (deployed as war) - no --prefix set but exactly this behaviour (2.338)

            Do you mind inspecting the missing icon element and provide the findings? That could help to provide additional information about the issue.

            notmyfault Alexander Brandes added a comment - Do you mind inspecting the missing icon element and provide the findings? That could help to provide additional information about the issue.

            Sure:

            <img src="/jenkinshttps://ourjenkins.de/jenkins/custom-avatar-cache/1ec36e9f1a1fb54db76fdc2a5a60b6c5.png?size=48x48" alt="Bitbucket Team/Project" width="48" tooltip="Bitbucket Team/Project" height="48" title="Bitbucket Team/Project">
            

            It seems to incorrectly add the full url after the path prefix (which is probably added via tomcat/servlet context path?)

            cschoell Christof Schoell added a comment - Sure: <img src= "/jenkinshttps: //ourjenkins.de/jenkins/custom-avatar-cache/1ec36e9f1a1fb54db76fdc2a5a60b6c5.png?size=48x48" alt= "Bitbucket Team/Project" width= "48" tooltip= "Bitbucket Team/Project" height= "48" title= "Bitbucket Team/Project" > It seems to incorrectly add the full url after the path prefix (which is probably added via tomcat/servlet context path?)
            notmyfault Alexander Brandes added a comment - - edited

            Yeah, that would be part of the issue I linked before.
            This issue targets the typo in the icon registry which was "icon-bitbucket-scmnavigator icon-<size>" instead of "icon-bitbucket-scm-navigator icon-<size>" before, that caused the default icon to not show.

            notmyfault Alexander Brandes added a comment - - edited Yeah, that would be part of the issue I linked before. This issue targets the typo in the icon registry which was "icon-bitbucket-scmnavigator icon-<size>" instead of "icon-bitbucket-scm-navigator icon-<size>" before, that caused the default icon to not show.
            basil Basil Crow added a comment -

            Between JENKINS-67823, JENKINS-67849, JENKINS-67869, and JENKINS-67877 I am having a hard time understanding what issues remain at the time of current writing. If you are still experiencing an issue and are running the latest weekly and latest plugins, please leave a comment in JENKINS-67823 (not this ticket!) so that we can assess what remains to be done for this work unit.

            basil Basil Crow added a comment - Between JENKINS-67823 , JENKINS-67849 , JENKINS-67869 , and JENKINS-67877 I am having a hard time understanding what issues remain at the time of current writing. If you are still experiencing an issue and are running the latest weekly and latest plugins, please leave a comment in JENKINS-67823 (not this ticket!) so that we can assess what remains to be done for this work unit.

            People

              notmyfault Alexander Brandes
              markewaite Mark Waite
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: