Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-67902

Tooltips are gone from matrix-auth table after core redesign (regression in 2.335)

    XMLWordPrintable

Details

    • matrix-auth-3.1.1

    Description

      Jenkins 2.335 no longer show tooltips on the checkboxes of the matrix-auth permissions table that make it easier to navigate large tables.

      Attachments

        1. after.png
          after.png
          233 kB
        2. before.png
          before.png
          387 kB

        Issue Links

          Activity

            danielbeck Daniel Beck created issue -
            danielbeck Daniel Beck made changes -
            Field Original Value New Value
            Attachment after.png [ 57356 ]
            Attachment before.png [ 57357 ]
            danielbeck Daniel Beck made changes -
            Description Jenkins 2.336, possibly older releases, no longer show tooltips on the checkboxes of the matrix-auth permissions table that make it easier to navigate large tables. Jenkins 2.336, possibly older releases, no longer show tooltips on the checkboxes of the matrix-auth permissions table that make it easier to navigate large tables.

            Still works as expected on 2.332.
            timja Tim Jacomb added a comment - cc janfaracik
            basil Basil Crow made changes -
            Link This issue is caused by JENKINS-68248 [ JENKINS-68248 ]
            basil Basil Crow made changes -
            Summary Tooltips are gone from matrix-auth table after core redesign Tooltips are gone from matrix-auth table after core redesign (regression in 2.335)
            danielbeck Daniel Beck made changes -
            Description Jenkins 2.336, possibly older releases, no longer show tooltips on the checkboxes of the matrix-auth permissions table that make it easier to navigate large tables.

            Still works as expected on 2.332.
            Jenkins 2.335 no longer show tooltips on the checkboxes of the matrix-auth permissions table that make it easier to navigate large tables.
            basil Basil Crow made changes -
            Priority Minor [ 4 ] Major [ 3 ]
            janfaracik Jan Faracik added a comment -

            Thanks for raising! Fix for this is up for review on the pluginĀ https://github.com/jenkinsci/matrix-auth-plugin/pull/116

            janfaracik Jan Faracik added a comment - Thanks for raising! Fix for this is up for review on the pluginĀ  https://github.com/jenkinsci/matrix-auth-plugin/pull/116
            basil Basil Crow made changes -
            Assignee Jan Faracik [ JIRAUSER136250 ]
            basil Basil Crow made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            basil Basil Crow made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            basil Basil Crow made changes -
            Remote Link This issue links to "jenkinsci/matrix-auth-plugin#116 (Web Link)" [ 27563 ]
            danielbeck Daniel Beck made changes -
            Component/s matrix-auth-plugin [ 18131 ]
            basil Basil Crow made changes -
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Fixed but Unreleased [ 10203 ]
            danielbeck Daniel Beck made changes -
            Released As matrix-auth-3.1.1
            Status Fixed but Unreleased [ 10203 ] Closed [ 6 ]

            People

              janfaracik Jan Faracik
              danielbeck Daniel Beck
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: