Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-68042

Help button alignment is wrong if no object is present to place it on (regression in 2.320)

    XMLWordPrintable

Details

    • 2.347, 2.346.1

    Description

      If the help button is not aligned to an object, for example a header, it's placed somewhere below the section it belongs to instead of right next to it:

       

      For reference, that's how it used to look on 2.263.3

      The same can be obtained at the notification URL dropdown:

      Compared to 2.263.3:

      Even if that is placed by a plugin, the same issue applies here too.

      This is a regression of the help button modernization, I didn't take a look yet which version this has been introduced in, however, it's present on 2.332.1 and could possibly be an lts candidate, once addressed.

      Attachments

        1. after.png
          after.png
          13 kB
        2. before.png
          before.png
          15 kB

        Issue Links

          Activity

            notmyfault Alexander Brandes created issue -
            notmyfault Alexander Brandes made changes -
            Field Original Value New Value
            Description If the help button is not aligned to an object, for example a header, it's placed somewhere below the section it belongs to instead of right next to it:

            !https://i.imgur.com/cJKHwL2.png!

             

            For reference, that's how it used to look on 2.263.3

            !https://i.imgur.com/H3B2vgL.png!

            The same can be obtained at the notification URL dropdown:

            !https://i.imgur.com/QEW2t3J.png!

            Compared to 2.263.3:

            !https://i.imgur.com/KKE3CGY.png!

            Even if that is placed by a plugin, the same issue applies here too.

            This is a regression of the help button modernization, I didn't take a look yet which version this has been introduced in, however, it's present on 2.332.1 and could possibly be an lts candidate, once addressed.
            If the help button is not aligned to an object, for example a header, it's placed somewhere below the section it belongs to instead of right next to it:

            !https://i.imgur.com/cJKHwL2.png!

             

            For reference, that's how it used to look on 2.263.3

            !https://i.imgur.com/EzY8HsP.png!

            The same can be obtained at the notification URL dropdown:

            !https://i.imgur.com/QEW2t3J.png!

            Compared to 2.263.3:

            !https://i.imgur.com/KKE3CGY.png!

            Even if that is placed by a plugin, the same issue applies here too.

            This is a regression of the help button modernization, I didn't take a look yet which version this has been introduced in, however, it's present on 2.332.1 and could possibly be an lts candidate, once addressed.
            basil Basil Crow made changes -
            Labels regression ui regression ux

            I was trying to reproduce the problem and pinpoint the source of the issue, but I cannot on the latest weekly nor on 2.332.2 on core help buttons. Are those screen shot from configuration of a specific plugin?

            alecharp Adrien Lecharpentier added a comment - I was trying to reproduce the problem and pinpoint the source of the issue, but I cannot on the latest weekly nor on 2.332.2 on core help buttons. Are those screen shot from configuration of a specific plugin?
            basil Basil Crow added a comment -

            Are those screen shot from configuration of a specific plugin?

            I did a git grep session.termination and found that the Session Termination button can be viewed at http://127.0.0.1:8080/user/admin/configure

            basil Basil Crow added a comment - Are those screen shot from configuration of a specific plugin? I did a git grep session.termination and found that the Session Termination button can be viewed at http://127.0.0.1:8080/user/admin/configure
            basil Basil Crow made changes -
            Summary Help button alignment is wrong if no object is present to place it on Help button alignment is wrong if no object is present to place it on (regression in 2.320)
            basil Basil Crow added a comment -

            I have attached before and after screenshots

            basil Basil Crow added a comment - I have attached before and after screenshots
            basil Basil Crow made changes -
            Attachment after.png [ 57667 ]
            Attachment before.png [ 57668 ]
            basil Basil Crow made changes -
            Link This issue is caused by JENKINS-68247 [ JENKINS-68247 ]
            basil Basil Crow added a comment - - edited Bisected this to https://github.com/jenkinsci/jenkins/pull/5842
            notmyfault Alexander Brandes made changes -
            Remote Link This issue links to "https://github.com/jenkinsci/jenkins/pull/6493 (Web Link)" [ 27584 ]
            notmyfault Alexander Brandes made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            notmyfault Alexander Brandes made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            basil Basil Crow made changes -
            Released As 2.347
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Fixed but Unreleased [ 10203 ]
            basil Basil Crow made changes -
            Status Fixed but Unreleased [ 10203 ] Closed [ 6 ]
            basil Basil Crow made changes -
            Labels regression ux lts-candidate regression ux
            notmyfault Alexander Brandes made changes -
            Labels lts-candidate regression ux 2.346.1-fixed lts-candidate regression ux
            notmyfault Alexander Brandes made changes -
            Labels 2.346.1-fixed lts-candidate regression ux 2.346.1-fixed regression ux
            notmyfault Alexander Brandes made changes -
            Released As 2.347 2.347, 2.346.1

            People

              Unassigned Unassigned
              notmyfault Alexander Brandes
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: