Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-68103

Clicking build progress bar no longer jumps to console output (regression in 2.340)

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • core
    • Jenkins version: 2.340
      Host: Debian 11 (Bullseye)
    • 2.344

    Description

      Clicking the progress bar of a build used to jump to the console output until 2.339. In 2.340 it jumps to the build's overview page.

      I always found that shortcut handy and hope this change is unintended .

      Edit: This seems to only happen when jumping from the job overview page.

      Attachments

        Issue Links

          Activity

            basil Basil Crow added a comment -

            I always found that shortcut handy

            Me too!

            basil Basil Crow added a comment - I always found that shortcut handy Me too!

            Is that replicable on different sorts of job types? Building a freestyle job links to the appropriate console tab on 2.342 for me:

            notmyfault Alexander Brandes added a comment - Is that replicable on different sorts of job types? Building a freestyle job links to the appropriate console tab on 2.342 for me:
            up_lange Urs Lange added a comment -

            Steps to reproduce:

            • docker run -p 8080:8080 -p 50000:50000 jenkins/jenkins
            • Suggested plugins
            • New Pipeline Job
            • This simple pipeline:
            pipeline {
                agent any
                stages {
                    stage('Hello') {
                        steps {
                            echo 'Hello World'
                            sleep 10
                            echo 'Bye world'
                        }
                    }
                }
            }
            
            up_lange Urs Lange added a comment - Steps to reproduce: docker run -p 8080:8080 -p 50000:50000 jenkins/jenkins Suggested plugins New Pipeline Job This simple pipeline: pipeline { agent any stages { stage( 'Hello' ) { steps { echo 'Hello World' sleep 10 echo 'Bye world' } } } }
            notmyfault Alexander Brandes added a comment - - edited

            With workflow-cps v2686.v7c37e0578401, the console redirect works fine for me. However, the area it is bound to is very small, clicking a few pixel to high jumps to the overview page:

            notmyfault Alexander Brandes added a comment - - edited With workflow-cps v2686.v7c37e0578401, the console redirect works fine for me. However, the area it is bound to is very small, clicking a few pixel to high jumps to the overview page:
            up_lange Urs Lange added a comment -

            Seems my aim is not on point then

            up_lange Urs Lange added a comment - Seems my aim is not on point then

            I tried with a fresh build of 2.340 and installing the latest pipeline plugin. It grabbed workflow-cps:2686.v7c37e0578401. I don't have the problem. The area of the link is of normal size.

            I'm using Firefox 98. What web browser are you using up_lange?

            alecharp Adrien Lecharpentier added a comment - I tried with a fresh build of 2.340 and installing the latest pipeline plugin. It grabbed workflow-cps:2686.v7c37e0578401 . I don't have the problem. The area of the link is of normal size. I'm using Firefox 98. What web browser are you using up_lange ?
            up_lange Urs Lange added a comment -

            I am currently using Firefox 99 and can reproduce the issue as described above (with the addition that the link indeed is correct but the clickable area is very small).

            up_lange Urs Lange added a comment - I am currently using Firefox 99 and can reproduce the issue as described above (with the addition that the link indeed is correct but the clickable area is very small).

            I'm sorry, the problem is limited or nit reproducible on my side on the controller home page. However I can reproduce it on the project page. I'm looking to see when this was introduced.

            alecharp Adrien Lecharpentier added a comment - I'm sorry, the problem is limited or nit reproducible on my side on the controller home page. However I can reproduce it on the project page. I'm looking to see when this was introduced.

            notmyfault I can reproduce the problem. Did you find it was resolved in a newer version?

            alecharp Adrien Lecharpentier added a comment - notmyfault I can reproduce the problem. Did you find it was resolved in a newer version?
            notmyfault Alexander Brandes added a comment - - edited

            On which kind of job type are you able to reproduce it? I don't see this being a regression, it just has a tiny interaction field that is hard to click if you are too high or too low.
            The only job type that does not link to the console is the maven integration, but that always used to be like that afaik, pipeline, freestyle, matrix/multimodule etc are fine based on my the browser tools.

            notmyfault Alexander Brandes added a comment - - edited On which kind of job type are you able to reproduce it? I don't see this being a regression, it just has a tiny interaction field that is hard to click if you are too high or too low. The only job type that does not link to the console is the maven integration, but that always used to be like that afaik, pipeline, freestyle, matrix/multimodule etc are fine based on my the browser tools.

            On a pipeline project, using firefox 98, when you are on the project page.
            What I ca see is that the link to the build page is overlapping with the progress bar, making at least half of the height of the progress bar not usable.

            alecharp Adrien Lecharpentier added a comment - On a pipeline project, using firefox 98, when you are on the project page. What I ca see is that the link to the build page is overlapping with the progress bar, making at least half of the height of the progress bar not usable.

            Update: it's working fine on 1f9d510 but stopped in 422efe996e. It seems that JENKINS-67396 and https://github.com/jenkinsci/jenkins/pull/6084 introduced the problem.

            alecharp Adrien Lecharpentier added a comment - Update: it's working fine on 1f9d510 but stopped in 422efe996e . It seems that JENKINS-67396 and https://github.com/jenkinsci/jenkins/pull/6084 introduced the problem.
            basil Basil Crow added a comment -

            Released in 2.344. up_lange Could you please verify that the issue has been resolved? Thanks!

            basil Basil Crow added a comment - Released in 2.344. up_lange Could you please verify that the issue has been resolved? Thanks!
            up_lange Urs Lange added a comment -

            Please excuse my late response, I was on vacation. The fix works fine, problem resolved for me. Thank you guys

            up_lange Urs Lange added a comment - Please excuse my late response, I was on vacation. The fix works fine, problem resolved for me. Thank you guys

            People

              janfaracik Jan Faracik
              up_lange Urs Lange
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: