Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-68538

New item dialog selects item name when editing Copy from

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Duplicate
    • core

    Description

      In Jenkins 2.347 (I did not check which release introduced this bug) the New Item dialog validation forces the selection of the Item Name (if empty) when I am trying to enter a value in the Copy From field.

      Steps to reproduce:

      1. Select New Item
      2. Click and select the text field Copy From (without entering a value in Item Name)
      3. Type a character
      4. Jenkins Validation writes error message "This field cannot be empty, please enter a valid name" in Item Name field.
      5. Jenkins moves focus from Copy From to Item Name

      Expected behavior

      • Jenkins should never change the focus while I am typing in a field just to present a validation message in another field. A validation message should only be visible if the user leaves a field (or presses ok)

      Attachments

        Issue Links

          Activity

            drulli Ulli Hafner created issue -
            drulli Ulli Hafner made changes -
            Field Original Value New Value
            Description In Jenkins 2.347 (I did not check since which release this is broken) the *New Item* dialog validation forces the selection of the *Item Name* (if empty) when I am trying to enter a value in the *Copy From* field.

            Steps to reproduce:
            # Select *New Item*
            # Click and select the text field *Copy From* (without entering a value in *Item Name*)
            # Type a character
            # Jenkins Validation writes error message "This field cannot be empty, please enter a valid name" in *Item Name* field.
            # Jenkins moves focus from *Copy From* to *Item Name*

            Expected behavior
            - Jenkins should never change the focus while I am typing in a field just to present a validation message. A validation message should only be visible if the user leaves the field (or presses ok)
            In Jenkins 2.347 (I did not check which release introduced this bug) the *New Item* dialog validation forces the selection of the *Item Name* (if empty) when I am trying to enter a value in the *Copy From* field.

            Steps to reproduce:
            # Select *New Item*
            # Click and select the text field *Copy From* (without entering a value in *Item Name*)
            # Type a character
            # Jenkins Validation writes error message "This field cannot be empty, please enter a valid name" in *Item Name* field.
            # Jenkins moves focus from *Copy From* to *Item Name*

            Expected behavior
            - Jenkins should never change the focus while I am typing in a field just to present a validation message. A validation message should only be visible if the user leaves the field (or presses ok)
            drulli Ulli Hafner made changes -
            Description In Jenkins 2.347 (I did not check which release introduced this bug) the *New Item* dialog validation forces the selection of the *Item Name* (if empty) when I am trying to enter a value in the *Copy From* field.

            Steps to reproduce:
            # Select *New Item*
            # Click and select the text field *Copy From* (without entering a value in *Item Name*)
            # Type a character
            # Jenkins Validation writes error message "This field cannot be empty, please enter a valid name" in *Item Name* field.
            # Jenkins moves focus from *Copy From* to *Item Name*

            Expected behavior
            - Jenkins should never change the focus while I am typing in a field just to present a validation message. A validation message should only be visible if the user leaves the field (or presses ok)
            In Jenkins 2.347 (I did not check which release introduced this bug) the *New Item* dialog validation forces the selection of the *Item Name* (if empty) when I am trying to enter a value in the *Copy From* field.

            Steps to reproduce:
            # Select *New Item*
            # Click and select the text field *Copy From* (without entering a value in *Item Name*)
            # Type a character
            # Jenkins Validation writes error message "This field cannot be empty, please enter a valid name" in *Item Name* field.
            # Jenkins moves focus from *Copy From* to *Item Name*

            Expected behavior
            - Jenkins should never change the focus while I am typing in a field just to present a validation message in another field. A validation message should only be visible if the user leaves the field (or presses ok)
            drulli Ulli Hafner made changes -
            Description In Jenkins 2.347 (I did not check which release introduced this bug) the *New Item* dialog validation forces the selection of the *Item Name* (if empty) when I am trying to enter a value in the *Copy From* field.

            Steps to reproduce:
            # Select *New Item*
            # Click and select the text field *Copy From* (without entering a value in *Item Name*)
            # Type a character
            # Jenkins Validation writes error message "This field cannot be empty, please enter a valid name" in *Item Name* field.
            # Jenkins moves focus from *Copy From* to *Item Name*

            Expected behavior
            - Jenkins should never change the focus while I am typing in a field just to present a validation message in another field. A validation message should only be visible if the user leaves the field (or presses ok)
            In Jenkins 2.347 (I did not check which release introduced this bug) the *New Item* dialog validation forces the selection of the *Item Name* (if empty) when I am trying to enter a value in the *Copy From* field.

            Steps to reproduce:
            # Select *New Item*
            # Click and select the text field *Copy From* (without entering a value in *Item Name*)
            # Type a character
            # Jenkins Validation writes error message "This field cannot be empty, please enter a valid name" in *Item Name* field.
            # Jenkins moves focus from *Copy From* to *Item Name*

            Expected behavior
            - Jenkins should never change the focus while I am typing in a field just to present a validation message in another field. A validation message should only be visible if the user leaves a field (or presses ok)
            basil Basil Crow made changes -
            Labels regression regression ux ux-untriaged
            markewaite Mark Waite added a comment - - edited

            This seems like a similar description to JENKINS-66530 that has existed for many years. I've confirmed that the problem also exists in Jenkins 2.277.4.

            markewaite Mark Waite added a comment - - edited This seems like a similar description to JENKINS-66530 that has existed for many years. I've confirmed that the problem also exists in Jenkins 2.277.4.
            markewaite Mark Waite made changes -
            Link This issue duplicates JENKINS-66530 [ JENKINS-66530 ]
            markewaite Mark Waite made changes -
            Labels regression ux ux-untriaged ux
            drulli Ulli Hafner added a comment -

            Interesting, I thought this has been caused by the UI refactoring, so I am closing this one...

            drulli Ulli Hafner added a comment - Interesting, I thought this has been caused by the UI refactoring, so I am closing this one...
            drulli Ulli Hafner made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]

            People

              Unassigned Unassigned
              drulli Ulli Hafner
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: