Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8700

"Node offline during build" and problems reconnecting.

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Blocker
    • Resolution: Duplicate
    • core
    • None
    • Windows Server 2003 (master - VMWare VM)
      Windows XP, SP2 (slave - VMWare VM)

    Description

      We have jobs that start out fine, get sources from Subversion fine, and then die after about 30 seconds of Python execution. It looks from the logs as if the slave connection fails and an attempt is made to reconnect, then the reconnection is rejected because it is thought to have already been made.

      We upgraded to Jenkins 1.396 from Hudson 1.310 and then 1.395 to resolve similar connection failures (see Hudson issue 5073). Building is impossible for us with this current version.

      Any workarounds or runtime parameters we can try? What could be causing the disconnections?

      Failing job log:
      Testing ENG-RTOS-2DGI-C9FATAL: command execution failed
      hudson.util.IOException2: Failed to join the process
      at hudson.Proc$RemoteProc.join(Proc.java:359)
      at hudson.Launcher$ProcStarter.join(Launcher.java:280)
      at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:82)
      at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:58)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:622)
      at hudson.model.Build$RunnerImpl.build(Build.java:172)
      at hudson.model.Build$RunnerImpl.doRun(Build.java:137)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:420)
      at hudson.model.Run.run(Run.java:1362)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:145)
      Caused by: java.util.concurrent.ExecutionException: hudson.remoting.RequestAbortedException: java.net.SocketException: socket closed
      at hudson.remoting.Request$1.get(Request.java:218)
      at hudson.remoting.Request$1.get(Request.java:172)
      at hudson.remoting.FutureAdapter.get(FutureAdapter.java:55)
      at hudson.Proc$RemoteProc.join(Proc.java:351)
      ... 12 more
      Caused by: hudson.remoting.RequestAbortedException: java.net.SocketException: socket closed
      at hudson.remoting.Request.abort(Request.java:257)
      at hudson.remoting.Channel.terminate(Channel.java:680)
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:971)
      Caused by: java.net.SocketException: socket closed
      at java.net.SocketInputStream.socketRead0(Native Method)
      at java.net.SocketInputStream.read(Unknown Source)
      at java.io.BufferedInputStream.fill(Unknown Source)
      at java.io.BufferedInputStream.read(Unknown Source)
      at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source)
      at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source)
      at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source)
      at java.io.ObjectInputStream.readObject0(Unknown Source)
      at java.io.ObjectInputStream.readObject(Unknown Source)
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:947)
      FATAL: Unable to delete script file C:\DOCUME~1\aditools\LOCALS~1\Temp\hudson53001.bat
      hudson.util.IOException2: remote file operation failed: C:\DOCUME~1\aditools\LOCALS~1\Temp\hudson53001.bat at hudson.remoting.Channel@a7cba9:ctse-test-xp-5
      at hudson.FilePath.act(FilePath.java:752)
      at hudson.FilePath.act(FilePath.java:738)
      at hudson.FilePath.delete(FilePath.java:993)
      at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:92)
      at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:58)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:622)
      at hudson.model.Build$RunnerImpl.build(Build.java:172)
      at hudson.model.Build$RunnerImpl.doRun(Build.java:137)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:420)
      at hudson.model.Run.run(Run.java:1362)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:145)
      Caused by: hudson.remoting.ChannelClosedException: channel is already closed
      at hudson.remoting.Channel.send(Channel.java:466)
      at hudson.remoting.Request.call(Request.java:105)
      at hudson.remoting.Channel.call(Channel.java:629)
      at hudson.FilePath.act(FilePath.java:745)
      ... 13 more
      Caused by: java.net.SocketException: socket closed
      at java.net.SocketInputStream.socketRead0(Native Method)
      at java.net.SocketInputStream.read(Unknown Source)
      at java.io.BufferedInputStream.fill(Unknown Source)
      at java.io.BufferedInputStream.read(Unknown Source)
      at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source)
      at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source)
      at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source)
      at java.io.ObjectInputStream.readObject0(Unknown Source)
      at java.io.ObjectInputStream.readObject(Unknown Source)
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:947)
      Looks like the node went offline during the build. Check the slave log for the details.details
      JNLP agent connected from /10.64.83.182

      FATAL: channel is already closed
      hudson.remoting.ChannelClosedException: channel is already closed
      at hudson.remoting.Channel.send(Channel.java:466)
      at hudson.remoting.Request.call(Request.java:105)
      at hudson.remoting.Channel.call(Channel.java:629)
      at hudson.Launcher$RemoteLauncher.kill(Launcher.java:744)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:441)
      at hudson.model.Run.run(Run.java:1362)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:145)
      Caused by: java.net.SocketException: socket closed
      at java.net.SocketInputStream.socketRead0(Native Method)
      at java.net.SocketInputStream.read(Unknown Source)
      at java.io.BufferedInputStream.fill(Unknown Source)
      at java.io.BufferedInputStream.read(Unknown Source)
      at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source)
      at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source)
      at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source)
      at java.io.ObjectInputStream.readObject0(Unknown Source)
      at java.io.ObjectInputStream.readObject(Unknown Source)
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:947)

      Jenkins log:

      Feb 4, 2011 11:28:18 AM hudson.TcpSlaveAgentListener$ConnectionHandler$1 onClosed
      WARNING: Connection #10 for + ctse-test-xp-5 terminated
      java.net.SocketException: socket closed
      at java.net.SocketInputStream.socketRead0(Native Method)
      at java.net.SocketInputStream.read(Unknown Source)
      at java.io.BufferedInputStream.fill(Unknown Source)
      at java.io.BufferedInputStream.read(Unknown Source)
      at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source)
      at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source)
      at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source)
      at java.io.ObjectInputStream.readObject0(Unknown Source)
      at java.io.ObjectInputStream.readObject(Unknown Source)
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:947)
      Feb 4, 2011 11:28:18 AM hudson.remoting.Channel$ReaderThread run
      SEVERE: I/O error in channel ctse-test-xp-5
      java.net.SocketException: socket closed
      at java.net.SocketInputStream.socketRead0(Native Method)
      at java.net.SocketInputStream.read(Unknown Source)
      at java.io.BufferedInputStream.fill(Unknown Source)
      at java.io.BufferedInputStream.read(Unknown Source)
      at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source)
      at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source)
      at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source)
      at java.io.ObjectInputStream.readObject0(Unknown Source)
      at java.io.ObjectInputStream.readObject(Unknown Source)
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:947)
      Feb 4, 2011 11:28:18 AM hudson.TcpSlaveAgentListener$ConnectionHandler runJnlp2Connect
      INFO: Disconnecting ctse-test-xp-5 as we are reconnected from the current peer
      Feb 4, 2011 11:28:18 AM hudson.TcpSlaveAgentListener$ConnectionHandler run
      INFO: Accepted connection #11 from /10.64.83.182:2467

      Attachments

        Issue Links

          Activity

            msacarny msacarny created issue -
            lacostej lacostej added a comment -

            Would you like to try a patched build containing fixes for JENKINS-8686 and see if that fixes your problem ?
            Take build 15 from http://coffeebreaks.org/software/jenkins/

            lacostej lacostej added a comment - Would you like to try a patched build containing fixes for JENKINS-8686 and see if that fixes your problem ? Take build 15 from http://coffeebreaks.org/software/jenkins/
            msacarny msacarny added a comment -

            I would love to and appreciate the quick reply. Now that we have reverted our system, however, I'll have to wait for the next planned maintenance window.

            msacarny msacarny added a comment - I would love to and appreciate the quick reply. Now that we have reverted our system, however, I'll have to wait for the next planned maintenance window.
            lacostej lacostej made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-5073 [ JENKINS-5073 ]
            msacarny msacarny added a comment -

            I was able to test the aforementioned patched build. One of our platforms that was unable to install Jenkins as a service now was able to do so. Excellent!

            Another of our platforms would crash due to failure to join process, as mentioned. No change in that case. Here is the log:

            ENG-RTOS-2DGI-C9FATAL: command execution failed hudson.util.IOException2: Failed to join the process at hudson.Proc$RemoteProc.join(Proc.java:359) at hudson.Launcher$ProcStarter.join(Launcher.java:280) at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:82) at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:58) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:622) at hudson.model.Build$RunnerImpl.build(Build.java:172) at hudson.model.Build$RunnerImpl.doRun(Build.java:137) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:420) at hudson.model.Run.run(Run.java:1362) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:145) Caused by: java.util.concurrent.ExecutionException: hudson.remoting.RequestAbortedException: java.net.SocketException: socket closed at hudson.remoting.Request$1.get(Request.java:218) at hudson.remoting.Request$1.get(Request.java:172) at hudson.remoting.FutureAdapter.get(FutureAdapter.java:55) at hudson.Proc$RemoteProc.join(Proc.java:351) ... 12 more Caused by: hudson.remoting.RequestAbortedException: java.net.SocketException: socket closed at hudson.remoting.Request.abort(Request.java:257) at hudson.remoting.Channel.terminate(Channel.java:680) at hudson.remoting.Channel$ReaderThread.run(Channel.java:971) Caused by: java.net.SocketException: socket closed at java.net.SocketInputStream.socketRead0(Native Method) at java.net.SocketInputStream.read(Unknown Source) at java.io.BufferedInputStream.fill(Unknown Source) at java.io.BufferedInputStream.read(Unknown Source) at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source) at java.io.ObjectInputStream.readObject0(Unknown Source) at java.io.ObjectInputStream.readObject(Unknown Source) at hudson.remoting.Channel$ReaderThread.run(Channel.java:947) FATAL: Unable to delete script file C:\DOCUME~1\aditools\LOCALS~1\Temp\hudson10048.bat hudson.util.IOException2: remote file operation failed: C:\DOCUME~1\aditools\LOCALS~1\Temp\hudson10048.bat at hudson.remoting.Channel@d99751:ctse-test-xp-5 at hudson.FilePath.act(FilePath.java:752) at hudson.FilePath.act(FilePath.java:738) at hudson.FilePath.delete(FilePath.java:993) at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:92) at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:58) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:622) at hudson.model.Build$RunnerImpl.build(Build.java:172) at hudson.model.Build$RunnerImpl.doRun(Build.java:137) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:420) at hudson.model.Run.run(Run.java:1362) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:145) Caused by: hudson.remoting.ChannelClosedException: channel is already closed at hudson.remoting.Channel.send(Channel.java:466) at hudson.remoting.Request.call(Request.java:105) at hudson.remoting.Channel.call(Channel.java:629) at hudson.FilePath.act(FilePath.java:745) ... 13 more Caused by: java.net.SocketException: socket closed at java.net.SocketInputStream.socketRead0(Native Method) at java.net.SocketInputStream.read(Unknown Source) at java.io.BufferedInputStream.fill(Unknown Source) at java.io.BufferedInputStream.read(Unknown Source) at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source) at java.io.ObjectInputStream.readObject0(Unknown Source) at java.io.ObjectInputStream.readObject(Unknown Source) at hudson.remoting.Channel$ReaderThread.run(Channel.java:947) Looks like the node went offline during the build. Check the slave log for the details.details
            JNLP agent connected from /10.64.83.182
            FATAL: channel is already closed hudson.remoting.ChannelClosedException: channel is already closed at hudson.remoting.Channel.send(Channel.java:466) at hudson.remoting.Request.call(Request.java:105) at hudson.remoting.Channel.call(Channel.java:629) at hudson.Launcher$RemoteLauncher.kill(Launcher.java:744) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:441) at hudson.model.Run.run(Run.java:1362) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:145) Caused by: java.net.SocketException: socket closed at java.net.SocketInputStream.socketRead0(Native Method) at java.net.SocketInputStream.read(Unknown Source) at java.io.BufferedInputStream.fill(Unknown Source) at java.io.BufferedInputStream.read(Unknown Source) at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source) at java.io.ObjectInputStream.readObject0(Unknown Source) at java.io.ObjectInputStream.readObject(Unknown Source) at hudson.remoting.Channel$ReaderThread.run(Channel.java:947)

            ***************************************************************************
            Here is the log at the slave:
            Feb 11, 2011 2:56:56 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Handshaking
            Feb 11, 2011 2:56:56 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Connected
            Feb 22, 2011 2:57:20 PM hudson.remoting.Channel$ReaderThread run
            SEVERE: I/O error in channel channel
            java.net.SocketTimeoutException: Read timed out
            at java.net.SocketInputStream.socketRead0(Native Method)
            at java.net.SocketInputStream.read(Unknown Source)
            at java.io.BufferedInputStream.fill(Unknown Source)
            at java.io.BufferedInputStream.read(Unknown Source)
            at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source)
            at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source)
            at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source)
            at java.io.ObjectInputStream.readObject0(Unknown Source)
            at java.io.ObjectInputStream.readObject(Unknown Source)
            at hudson.remoting.Channel$ReaderThread.run(Channel.java:947)
            Feb 22, 2011 2:57:21 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Terminated
            Feb 11, 2011 2:57:30 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Locating server among http://ctse-team/jenkins/
            Feb 11, 2011 2:57:30 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Connecting to ctse-team:2517
            Feb 11, 2011 2:57:30 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Handshaking
            Feb 11, 2011 2:57:31 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Connected
            Feb 16, 2011 2:57:33 PM hudson.remoting.Channel$ReaderThread run
            SEVERE: I/O error in channel channel
            java.net.SocketTimeoutException: Read timed out
            at java.net.SocketInputStream.socketRead0(Native Method)
            at java.net.SocketInputStream.read(Unknown Source)
            at java.io.BufferedInputStream.fill(Unknown Source)
            at java.io.BufferedInputStream.read(Unknown Source)
            at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source)
            at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source)
            at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source)
            at java.io.ObjectInputStream.readObject0(Unknown Source)
            at java.io.ObjectInputStream.readObject(Unknown Source)
            at hudson.remoting.Channel$ReaderThread.run(Channel.java:947)
            Feb 16, 2011 2:57:33 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Terminated
            Feb 11, 2011 2:57:42 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Locating server among http://ctse-team/jenkins/
            Feb 11, 2011 2:57:42 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Connecting to ctse-team:2517
            Feb 11, 2011 2:57:42 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Handshaking
            Feb 11, 2011 2:57:43 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Connected
            Feb 16, 2011 2:57:48 PM hudson.remoting.Channel$ReaderThread run
            SEVERE: I/O error in channel channel
            java.net.SocketTimeoutException: Read timed out
            at java.net.SocketInputStream.socketRead0(Native Method)
            at java.net.SocketInputStream.read(Unknown Source)
            at java.io.BufferedInputStream.fill(Unknown Source)
            at java.io.BufferedInputStream.read(Unknown Source)
            at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source)
            at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source)
            at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source)
            at java.io.ObjectInputStream.readObject0(Unknown Source)
            at java.io.ObjectInputStream.readObject(Unknown Source)
            at hudson.remoting.Channel$ReaderThread.run(Channel.java:947)
            Feb 16, 2011 2:57:48 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Terminated
            Feb 23, 2012 2:57:57 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Locating server among http://ctse-team/jenkins/
            Feb 23, 2012 2:57:57 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Connecting to ctse-team:2517
            Feb 23, 2012 2:57:57 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Handshaking
            Feb 11, 2011 2:57:58 PM hudson.remoting.jnlp.Main$CuiListener status
            INFO: Connected
            Exception in thread "cmd /c call C:\DOCUME~1\aditools\LOCALS~1\Temp\hudson10048.bat: stdout copier" java.lang.RuntimeException: hudson.remoting.ChannelClosedException: channel is already closed
            at hudson.util.StreamCopyThread.run(StreamCopyThread.java:70)
            Caused by: hudson.remoting.ChannelClosedException: channel is already closed
            at hudson.remoting.Channel.send(Channel.java:466)
            at hudson.remoting.ProxyOutputStream._write(ProxyOutputStream.java:123)
            at hudson.remoting.ProxyOutputStream.write(ProxyOutputStream.java:103)
            at hudson.remoting.RemoteOutputStream.write(RemoteOutputStream.java:110)
            at hudson.util.StreamCopyThread.run(StreamCopyThread.java:61)
            Caused by: java.net.SocketTimeoutException: Read timed out
            at java.net.SocketInputStream.socketRead0(Native Method)
            at java.net.SocketInputStream.read(Unknown Source)
            at java.io.BufferedInputStream.fill(Unknown Source)
            at java.io.BufferedInputStream.read(Unknown Source)
            at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source)
            at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source)
            at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source)
            at java.io.ObjectInputStream.readObject0(Unknown Source)
            at java.io.ObjectInputStream.readObject(Unknown Source)
            at hudson.remoting.Channel$ReaderThread.run(Channel.java:947)

            So, it looks like partial success. Thanks again for your help.

            msacarny msacarny added a comment - I was able to test the aforementioned patched build. One of our platforms that was unable to install Jenkins as a service now was able to do so. Excellent! Another of our platforms would crash due to failure to join process, as mentioned. No change in that case. Here is the log: ENG-RTOS-2DGI-C9FATAL: command execution failed hudson.util.IOException2: Failed to join the process at hudson.Proc$RemoteProc.join(Proc.java:359) at hudson.Launcher$ProcStarter.join(Launcher.java:280) at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:82) at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:58) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:622) at hudson.model.Build$RunnerImpl.build(Build.java:172) at hudson.model.Build$RunnerImpl.doRun(Build.java:137) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:420) at hudson.model.Run.run(Run.java:1362) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:145) Caused by: java.util.concurrent.ExecutionException: hudson.remoting.RequestAbortedException: java.net.SocketException: socket closed at hudson.remoting.Request$1.get(Request.java:218) at hudson.remoting.Request$1.get(Request.java:172) at hudson.remoting.FutureAdapter.get(FutureAdapter.java:55) at hudson.Proc$RemoteProc.join(Proc.java:351) ... 12 more Caused by: hudson.remoting.RequestAbortedException: java.net.SocketException: socket closed at hudson.remoting.Request.abort(Request.java:257) at hudson.remoting.Channel.terminate(Channel.java:680) at hudson.remoting.Channel$ReaderThread.run(Channel.java:971) Caused by: java.net.SocketException: socket closed at java.net.SocketInputStream.socketRead0(Native Method) at java.net.SocketInputStream.read(Unknown Source) at java.io.BufferedInputStream.fill(Unknown Source) at java.io.BufferedInputStream.read(Unknown Source) at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source) at java.io.ObjectInputStream.readObject0(Unknown Source) at java.io.ObjectInputStream.readObject(Unknown Source) at hudson.remoting.Channel$ReaderThread.run(Channel.java:947) FATAL: Unable to delete script file C:\DOCUME~1\aditools\LOCALS~1\Temp\hudson10048.bat hudson.util.IOException2: remote file operation failed: C:\DOCUME~1\aditools\LOCALS~1\Temp\hudson10048.bat at hudson.remoting.Channel@d99751:ctse-test-xp-5 at hudson.FilePath.act(FilePath.java:752) at hudson.FilePath.act(FilePath.java:738) at hudson.FilePath.delete(FilePath.java:993) at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:92) at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:58) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:622) at hudson.model.Build$RunnerImpl.build(Build.java:172) at hudson.model.Build$RunnerImpl.doRun(Build.java:137) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:420) at hudson.model.Run.run(Run.java:1362) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:145) Caused by: hudson.remoting.ChannelClosedException: channel is already closed at hudson.remoting.Channel.send(Channel.java:466) at hudson.remoting.Request.call(Request.java:105) at hudson.remoting.Channel.call(Channel.java:629) at hudson.FilePath.act(FilePath.java:745) ... 13 more Caused by: java.net.SocketException: socket closed at java.net.SocketInputStream.socketRead0(Native Method) at java.net.SocketInputStream.read(Unknown Source) at java.io.BufferedInputStream.fill(Unknown Source) at java.io.BufferedInputStream.read(Unknown Source) at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source) at java.io.ObjectInputStream.readObject0(Unknown Source) at java.io.ObjectInputStream.readObject(Unknown Source) at hudson.remoting.Channel$ReaderThread.run(Channel.java:947) Looks like the node went offline during the build. Check the slave log for the details.details JNLP agent connected from /10.64.83.182 FATAL: channel is already closed hudson.remoting.ChannelClosedException: channel is already closed at hudson.remoting.Channel.send(Channel.java:466) at hudson.remoting.Request.call(Request.java:105) at hudson.remoting.Channel.call(Channel.java:629) at hudson.Launcher$RemoteLauncher.kill(Launcher.java:744) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:441) at hudson.model.Run.run(Run.java:1362) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:145) Caused by: java.net.SocketException: socket closed at java.net.SocketInputStream.socketRead0(Native Method) at java.net.SocketInputStream.read(Unknown Source) at java.io.BufferedInputStream.fill(Unknown Source) at java.io.BufferedInputStream.read(Unknown Source) at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source) at java.io.ObjectInputStream.readObject0(Unknown Source) at java.io.ObjectInputStream.readObject(Unknown Source) at hudson.remoting.Channel$ReaderThread.run(Channel.java:947) *************************************************************************** Here is the log at the slave: Feb 11, 2011 2:56:56 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Handshaking Feb 11, 2011 2:56:56 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Connected Feb 22, 2011 2:57:20 PM hudson.remoting.Channel$ReaderThread run SEVERE: I/O error in channel channel java.net.SocketTimeoutException: Read timed out at java.net.SocketInputStream.socketRead0(Native Method) at java.net.SocketInputStream.read(Unknown Source) at java.io.BufferedInputStream.fill(Unknown Source) at java.io.BufferedInputStream.read(Unknown Source) at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source) at java.io.ObjectInputStream.readObject0(Unknown Source) at java.io.ObjectInputStream.readObject(Unknown Source) at hudson.remoting.Channel$ReaderThread.run(Channel.java:947) Feb 22, 2011 2:57:21 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Terminated Feb 11, 2011 2:57:30 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Locating server among http://ctse-team/jenkins/ Feb 11, 2011 2:57:30 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Connecting to ctse-team:2517 Feb 11, 2011 2:57:30 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Handshaking Feb 11, 2011 2:57:31 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Connected Feb 16, 2011 2:57:33 PM hudson.remoting.Channel$ReaderThread run SEVERE: I/O error in channel channel java.net.SocketTimeoutException: Read timed out at java.net.SocketInputStream.socketRead0(Native Method) at java.net.SocketInputStream.read(Unknown Source) at java.io.BufferedInputStream.fill(Unknown Source) at java.io.BufferedInputStream.read(Unknown Source) at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source) at java.io.ObjectInputStream.readObject0(Unknown Source) at java.io.ObjectInputStream.readObject(Unknown Source) at hudson.remoting.Channel$ReaderThread.run(Channel.java:947) Feb 16, 2011 2:57:33 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Terminated Feb 11, 2011 2:57:42 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Locating server among http://ctse-team/jenkins/ Feb 11, 2011 2:57:42 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Connecting to ctse-team:2517 Feb 11, 2011 2:57:42 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Handshaking Feb 11, 2011 2:57:43 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Connected Feb 16, 2011 2:57:48 PM hudson.remoting.Channel$ReaderThread run SEVERE: I/O error in channel channel java.net.SocketTimeoutException: Read timed out at java.net.SocketInputStream.socketRead0(Native Method) at java.net.SocketInputStream.read(Unknown Source) at java.io.BufferedInputStream.fill(Unknown Source) at java.io.BufferedInputStream.read(Unknown Source) at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source) at java.io.ObjectInputStream.readObject0(Unknown Source) at java.io.ObjectInputStream.readObject(Unknown Source) at hudson.remoting.Channel$ReaderThread.run(Channel.java:947) Feb 16, 2011 2:57:48 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Terminated Feb 23, 2012 2:57:57 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Locating server among http://ctse-team/jenkins/ Feb 23, 2012 2:57:57 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Connecting to ctse-team:2517 Feb 23, 2012 2:57:57 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Handshaking Feb 11, 2011 2:57:58 PM hudson.remoting.jnlp.Main$CuiListener status INFO: Connected Exception in thread "cmd /c call C:\DOCUME~1\aditools\LOCALS~1\Temp\hudson10048.bat: stdout copier" java.lang.RuntimeException: hudson.remoting.ChannelClosedException: channel is already closed at hudson.util.StreamCopyThread.run(StreamCopyThread.java:70) Caused by: hudson.remoting.ChannelClosedException: channel is already closed at hudson.remoting.Channel.send(Channel.java:466) at hudson.remoting.ProxyOutputStream._write(ProxyOutputStream.java:123) at hudson.remoting.ProxyOutputStream.write(ProxyOutputStream.java:103) at hudson.remoting.RemoteOutputStream.write(RemoteOutputStream.java:110) at hudson.util.StreamCopyThread.run(StreamCopyThread.java:61) Caused by: java.net.SocketTimeoutException: Read timed out at java.net.SocketInputStream.socketRead0(Native Method) at java.net.SocketInputStream.read(Unknown Source) at java.io.BufferedInputStream.fill(Unknown Source) at java.io.BufferedInputStream.read(Unknown Source) at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peek(Unknown Source) at java.io.ObjectInputStream$BlockDataInputStream.peekByte(Unknown Source) at java.io.ObjectInputStream.readObject0(Unknown Source) at java.io.ObjectInputStream.readObject(Unknown Source) at hudson.remoting.Channel$ReaderThread.run(Channel.java:947) So, it looks like partial success. Thanks again for your help.
            jglick Jesse Glick made changes -
            Link This issue duplicates JENKINS-1948 [ JENKINS-1948 ]
            jglick Jesse Glick made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 138844 ] JNJira + In-Review [ 188175 ]

            People

              Unassigned Unassigned
              msacarny msacarny
              Votes:
              4 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: