Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9327

Support filter on all build variables, not just build parameters

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • copyartifact-plugin
    • None
    • Jenkins 1.405, Copy Artifacts plugin 1.15

    Description

      I try to copy artifacts built from a specific git branch by entering

      MyProj/GIT_BRANCH=master
      

      in the "Project name" field. This displays an error:

      No such project 'MyProj/GIT_BRANCH=master'. Did you mean ...
      

      After saving the config, the Project name remains blank.

      Attachments

        Activity

          Code changed in jenkins
          User: alanharder
          Path:
          src/main/java/hudson/plugins/copyartifact/CopyArtifact.java
          src/main/java/hudson/plugins/copyartifact/ParametersBuildFilter.java
          src/main/resources/hudson/plugins/copyartifact/CopyArtifact/help-projectName.html
          src/test/java/hudson/plugins/copyartifact/CopyArtifactTest.java
          http://jenkins-ci.org/commit/copyartifact-plugin/d88baa76cc716584848f2f9a3c71d2b9628e3c0e
          Log:
          [FIXED JENKINS-9327] match filters against all EnvVars, not just build parameters

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: alanharder Path: src/main/java/hudson/plugins/copyartifact/CopyArtifact.java src/main/java/hudson/plugins/copyartifact/ParametersBuildFilter.java src/main/resources/hudson/plugins/copyartifact/CopyArtifact/help-projectName.html src/test/java/hudson/plugins/copyartifact/CopyArtifactTest.java http://jenkins-ci.org/commit/copyartifact-plugin/d88baa76cc716584848f2f9a3c71d2b9628e3c0e Log: [FIXED JENKINS-9327] match filters against all EnvVars, not just build parameters
          mbetter Marcus Better added a comment -

          Ok, then please consider this as a request for enhancement

          mbetter Marcus Better added a comment - Ok, then please consider this as a request for enhancement
          mindless Alan Harder added a comment -

          Correct, it only filters on build parameters.

          mindless Alan Harder added a comment - Correct, it only filters on build parameters.
          mbetter Marcus Better added a comment -

          It's a regular free-style project. I'm trying to filter on the value of a build variable. Maybe it can only filter on build parameters with this syntax?

          mbetter Marcus Better added a comment - It's a regular free-style project. I'm trying to filter on the value of a build variable. Maybe it can only filter on build parameters with this syntax?
          mindless Alan Harder added a comment -

          What type of project is "MyProj"? This could work if it is a matrix (multiconfiguration) project and has a single axis called GIT_BRANCH.
          If the validation tells you it is not valid and you click save anyway, it is expected that a blank value is saved. Not sure what the issue is here..

          mindless Alan Harder added a comment - What type of project is "MyProj"? This could work if it is a matrix (multiconfiguration) project and has a single axis called GIT_BRANCH. If the validation tells you it is not valid and you click save anyway, it is expected that a blank value is saved. Not sure what the issue is here..

          People

            Unassigned Unassigned
            mbetter Marcus Better
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: