Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9656

Jenkines 1.411 downgrade options are incorrect

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • core
    • None

    Description

      We were running Jenkins v1.410 and upgraded to v1.411. Now the "Manage Jenkins" page, under "Restore the previous version of Jenkins", offers me the option to downgrade to 1.395. As far as I remember, it used to offer the option to downgrade to whatever the previously installed release was.

      Another user has confirmed that they also see this.

      Attachments

        Activity

          mwebber Matthew Webber created issue -

          I can confirm the issue, too.

          gordin Christoph Vogtländer added a comment - I can confirm the issue, too.

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          changelog.html
          core/src/main/java/hudson/model/UpdateCenter.java
          http://jenkins-ci.org/commit/jenkins/d18f3cadca8fe81b45df79be1ce7f6c3e3f62f6f
          Log:
          [FIXED JENKINS-9656] downgrade button shows 1.395 incorrectly

          Compare: https://github.com/jenkinsci/jenkins/compare/4c1a377...d18f3ca

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Kohsuke Kawaguchi Path: changelog.html core/src/main/java/hudson/model/UpdateCenter.java http://jenkins-ci.org/commit/jenkins/d18f3cadca8fe81b45df79be1ce7f6c3e3f62f6f Log: [FIXED JENKINS-9656] downgrade button shows 1.395 incorrectly Compare: https://github.com/jenkinsci/jenkins/compare/4c1a377...d18f3ca
          scm_issue_link SCM/JIRA link daemon made changes -
          Field Original Value New Value
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          dogfood dogfood added a comment -

          Integrated in jenkins_main_trunk #788
          [FIXED JENKINS-9656] downgrade button shows 1.395 incorrectly

          Kohsuke Kawaguchi : d18f3cadca8fe81b45df79be1ce7f6c3e3f62f6f
          Files :

          • changelog.html
          • core/src/main/java/hudson/model/UpdateCenter.java
          dogfood dogfood added a comment - Integrated in jenkins_main_trunk #788 [FIXED JENKINS-9656] downgrade button shows 1.395 incorrectly Kohsuke Kawaguchi : d18f3cadca8fe81b45df79be1ce7f6c3e3f62f6f Files : changelog.html core/src/main/java/hudson/model/UpdateCenter.java
          tdtappe Heiko Tappe added a comment -

          I thought this would have been solved in 1.412 but it isn't. In which version will this be solved?

          --Heiko

          tdtappe Heiko Tappe added a comment - I thought this would have been solved in 1.412 but it isn't. In which version will this be solved? --Heiko
          arzala arzala added a comment -

          This seems interesting issue. However for us, we do not have this auto upgrade/downgrade option at all like it was in Hudson. We now have 1.411 and as part of upgrade we could just see following line under "Manage Jenkins"

          New version of Jenkins (1.413) is available for download (changelog).

          What is the reason for not being able to auto upgrade? We used guide to migrate to Hudson => Jenkins rather than whole new fresh setup.

          arzala arzala added a comment - This seems interesting issue. However for us, we do not have this auto upgrade/downgrade option at all like it was in Hudson. We now have 1.411 and as part of upgrade we could just see following line under "Manage Jenkins" New version of Jenkins (1.413) is available for download (changelog). What is the reason for not being able to auto upgrade? We used guide to migrate to Hudson => Jenkins rather than whole new fresh setup.

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          changelog.html
          core/src/main/java/hudson/model/UpdateCenter.java
          http://jenkins-ci.org/commit/jenkins/d18f3cadca8fe81b45df79be1ce7f6c3e3f62f6f
          Log:
          [FIXED JENKINS-9656] downgrade button shows 1.395 incorrectly

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Kohsuke Kawaguchi Path: changelog.html core/src/main/java/hudson/model/UpdateCenter.java http://jenkins-ci.org/commit/jenkins/d18f3cadca8fe81b45df79be1ce7f6c3e3f62f6f Log: [FIXED JENKINS-9656] downgrade button shows 1.395 incorrectly

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          changelog.html
          core/src/main/java/hudson/model/UpdateCenter.java
          http://jenkins-ci.org/commit/jenkins/d18f3cadca8fe81b45df79be1ce7f6c3e3f62f6f
          Log:
          [FIXED JENKINS-9656] downgrade button shows 1.395 incorrectly

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Kohsuke Kawaguchi Path: changelog.html core/src/main/java/hudson/model/UpdateCenter.java http://jenkins-ci.org/commit/jenkins/d18f3cadca8fe81b45df79be1ce7f6c3e3f62f6f Log: [FIXED JENKINS-9656] downgrade button shows 1.395 incorrectly
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 139830 ] JNJira + In-Review [ 188706 ]

          People

            Unassigned Unassigned
            mwebber Matthew Webber
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: