Uploaded image for project: 'Jenkins Website'
  1. Jenkins Website
  2. WEBSITE-428

Asciidoc monospace formatting inconsistent due to compat-mode

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Take the following asciidoc and put it on the jenkin.io website:

       

      *bold phrase* & **char**acter**s**
      
      _italic phrase_ & __char__acter__s__
      
      *_bold italic phrase_* & **__char__**acter**__s__**
      
      `monospace phrase {plus} link:.[this page]` &
      ``char{plus}``acter``s``
      
      +monospace phrase {plus} link:.[this page]+ &
      ++char{plus}++acter++s++ (plus)
      
      `*monospace bold phrase*` & ``**char**``acter``**s**``
      
      `_monospace italic phrase_` & ``__char__``acter``__s__``
      
      `*_monospace bold {plus} italic phrase_*` &
      ``**__char{plus}__**``acter``**__s__**``
      
      *_`monospace bold {plus} italic phrase`_* &
      **__``char{plus}``__**acter**__``s``__** (inside)
      
      +*_monospace pass-through NOT bold {plus} italic phrase_*+ &
      ++**__char{plus}__**++acter++**__s__**++ (plus)
      
      *_+monospace pass-through bold {plus} italic phrase+_* &
      **__++char{plus}++__**acter**__++s++__** (plus inside)
      

       

      What you will see is this (notice the double backticks do not format as monospace): 

       

      If you view this using the Chrome Asciidoc viewer, you get this: 

       

      It is clear that jenkins.io is wrong and producing bad output: the double back-tick formatting needs to be fixed.  Once that is done the plus formatting might also be fixed or might not, but it is also unclear what the fully correct behavior is.  

      The following two sources do not agree:

      http://asciidoctor.org/docs/asciidoc-syntax-quick-reference/ [
      http://asciidoc.org/userguide.html#_text_formatting]

      NOTE:

      The GitHub Asciidoc viewer behaves the same as the chrome extension. 

       

      I've marked this as a minor issue because it only crops up in corner cases around monospace formatting, but is does come up and it is problematic - it result in people not knowing how to mark their text to get consistent monospace formatting.

       

       

       

       

        Attachments

          Issue Links

            Activity

            bitwiseman Liam Newman added a comment -

            Per https://github.com/asciidoctor/asciidoctor.org/pull/742 

            This issue is caused by jenkins.io being in compat-mode.

            We should look at taking the steps in http://asciidoctor.org/docs/migration/ to move to the current format.


              People

              Assignee:
              bitwiseman Liam Newman
              Reporter:
              bitwiseman Liam Newman
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: