Uploaded image for project: 'Jenkins Website'
  1. Jenkins Website
  2. WEBSITE-469

Site build no longer fails when pages fail to build

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Tracking issue for what I discovered in https://github.com/jenkins-infra/jenkins.io/pull/1386

      Successful PR builds apparently mean nothing anymore.

      I know this worked a while back, my wild guess is that the switch to make now swallows build errors.

        Attachments

          Issue Links

            Activity

            zbynek Zbynek Konecny added a comment -

            Problem is that the build relies on exit value from awestruct (AFAICT not caused by any changes to jenkins.io).

            Upstream PR: https://github.com/awestruct/awestruct/pull/543

            zbynek Zbynek Konecny added a comment - - edited

            Upstream released as awestruct 0.6.0-alpha3 and used in https://github.com/jenkins-infra/jenkins.io/pull/2423 .

            Verification: https://github.com/jenkins-infra/jenkins.io/pull/2469


              People

              Assignee:
              zbynek Zbynek Konecny
              Reporter:
              danielbeck Daniel Beck
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: