Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10348

Git 1.1.9 plugin breaks remote name cleaning

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • git-plugin
    • None
    • Ubuntu Linux LTS

    Description

      We use the Git plugin to support an internal continuous test deployment setup where Jenkins uses origin/master to retrieve the latest code to build and Git Publisher pushes to our test server (platinum/master) where a git post-receive hook deploys the code.

      This was working well with 1.1.6 and recently started failing with 1.1.9 any time the workspace exists and the prune remote branches option is enabled. It appears to be attempting to retrieve the remote branch's URL before the remote has been configured - when I run a "git remote show" in that directory it shows only origin.

      Started by user cadams
      Checkout:workspace / /var/lib/jenkins/jobs/prj-trunk/workspace - hudson.remoting.LocalChannel@14c55ea
      Using strategy: Default
      Last Built Revision: Revision 519ee2ad1f4ef32519ecf8c627e0b24e3f6df020 (origin/master)
      Checkout:prj / /var/lib/jenkins/jobs/prj-trunk/workspace/prj - hudson.remoting.LocalChannel@14c55ea
      Pruning obsolete local branches
      FATAL: Error performing command: git config --get remote.platinum.url
      Command "git config --get remote.platinum.url" returned status code 1: 
      hudson.plugins.git.GitException: Error performing command: git config --get remote.platinum.url
      Command "git config --get remote.platinum.url" returned status code 1: 
      	at hudson.plugins.git.GitAPI.launchCommandIn(GitAPI.java:742)
      	at hudson.plugins.git.GitAPI.launchCommand(GitAPI.java:707)
      	at hudson.plugins.git.GitAPI.launchCommand(GitAPI.java:717)
      	at hudson.plugins.git.GitAPI.getRemoteUrl(GitAPI.java:428)
      	at hudson.plugins.git.GitAPI.prune(GitAPI.java:255)
      	at hudson.plugins.git.GitSCM$2.invoke(GitSCM.java:934)
      	at hudson.plugins.git.GitSCM$2.invoke(GitSCM.java:908)
      	at hudson.FilePath.act(FilePath.java:758)
      	at hudson.FilePath.act(FilePath.java:740)
      	at hudson.plugins.git.GitSCM.checkout(GitSCM.java:908)
      	at hudson.model.AbstractProject.checkout(AbstractProject.java:1184)
      	at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:537)
      	at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:425)
      	at hudson.model.Run.run(Run.java:1376)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:175)
      Caused by: hudson.plugins.git.GitException: Command "git config --get remote.platinum.url" returned status code 1: 
      	at hudson.plugins.git.GitAPI.launchCommandIn(GitAPI.java:737)
      	... 16 more
      

      Attachments

        Activity

          Code changed in jenkins
          User: Andrew Bayer
          Path:
          src/main/java/hudson/plugins/git/GitSCM.java
          http://jenkins-ci.org/commit/git-plugin/dc415ec38e7fd38475fe31c3abe68b73136899bd
          Log:
          [FIXED JENKINS-10348] Moved prune to after fetch.

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Andrew Bayer Path: src/main/java/hudson/plugins/git/GitSCM.java http://jenkins-ci.org/commit/git-plugin/dc415ec38e7fd38475fe31c3abe68b73136899bd Log: [FIXED JENKINS-10348] Moved prune to after fetch.
          dogfood dogfood added a comment -

          Integrated in plugins_git-plugin #195
          [FIXED JENKINS-10348] Moved prune to after fetch.

          Andrew Bayer : dc415ec38e7fd38475fe31c3abe68b73136899bd
          Files :

          • src/main/java/hudson/plugins/git/GitSCM.java
          dogfood dogfood added a comment - Integrated in plugins_git-plugin #195 [FIXED JENKINS-10348] Moved prune to after fetch. Andrew Bayer : dc415ec38e7fd38475fe31c3abe68b73136899bd Files : src/main/java/hudson/plugins/git/GitSCM.java

          People

            abayer Andrew Bayer
            acdha acdha
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: