Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1054

Version 1.159 broke SCP plugin.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Upgrading Hudson to version 1.159 breaks the SCP plugin. The plugin fails to
      load with the following error:

      29/11/2007 12:16:58 hudson.PluginManager <init> SEVERE: Failed to load a plug-in scp
      hudson.util.IOException2: Failed to initialize
      at hudson.PluginWrapper.load(PluginWrapper.java:253)
      at hudson.PluginManager.<init>(PluginManager.java:90)
      at hudson.model.Hudson.<init>(Hudson.java:235)
      at hudson.WebAppMain$1.run(WebAppMain.java:109)
      Caused by: java.lang.NoClassDefFoundError: com/jcraft/jsch/SftpException
      at be.certipost.hudson.plugin.PluginImpl.start(PluginImpl.java:18)
      at hudson.PluginWrapper.load(PluginWrapper.java:250)
      ... 3 more

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed in the scp plugin 1.2.


            People

            Assignee:
            kohsuke Kohsuke Kawaguchi
            Reporter:
            abonko abonko
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: