Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11104

Wsadmin Command not working with "sudo wsadmin"

    XMLWordPrintable

Details

    • Bug
    • Resolution: Fixed
    • Major
    • was-builder-plugin
    • None
    • Jenkins 1.430
      WAS Builder Plugin 1.6
      Debian GNU/Linux 2.6.32-5-amd64

    Description

      I'm trying to use the "Wsadmin Command" feature, but it is not working. It seems Jenkins is treating the field content as a single command.

      This is the Console Output I'm receiving (note the quotation marks around what came from the "Wsadmin Command" field):Using user admin defined at the server level
      $ "/usr/bin/sudo /home/was/IBM/WebSphere/AppServer01/bin/wsadmin.sh" -conntype SOAP -host zefiro.cit -port 8880 -user admin -password ******** -lang jython -f "/var/lib/jenkins/jobs/AVD ZEFIRO/workspace/newDeploy.py" "AVD ZEFIRO" zefiro Vendas
      FATAL: Wsadmin execution failed
      Build step 'IBM WebSphere Application Server 6.x/7.x' marked build as failure
      Checking console output
      Finished: FAILURE

      Jenkins' log doesn't say anything usefull, but this:

      Sep 19, 2011 4:18:01 PM hudson.model.Run runINFO: AVD ZEFIRO #12 main build action completed: FAILURE

      My prime suspects are the quotation marks around the "sudo wsadmin" pair.

      I'm using Jenkins 1.430 and WAS Builder Plugin 1.6.

      Attachments

        Activity

          People

            rseguy Romain Seguy
            helenov Heleno Valle
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: