Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11398

Cobertura gives LinkageError in new Jenkins version

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • cobertura-plugin
    • None
    • Suse linux desktop 10.2 (64-bit), Jenkins 1.434
      CentOS release 5.4 (64-bit), Jenkins 1.444-1.1

    Description

      After upgrading Jenkins to 1.434, I get the following error during Jenkins startup:

      WARNING: Failed to load hudson.plugins.cobertura.dashboard.CoverageTablePortlet$DescriptorImpl
      java.lang.LinkageError: Failed to resolve class hudson.plugins.cobertura.dashboard.CoverageTablePortlet$DescriptorImpl
      	at hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule.resolve(ExtensionFinder.java:294)
      	at hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule.configure(ExtensionFinder.java:325)
      	at com.google.inject.AbstractModule.configure(AbstractModule.java:59)
      	at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:223)
      	at com.google.inject.spi.Elements.getElements(Elements.java:101)
      	at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:133)
      	at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:103)
      	at com.google.inject.Guice.createInjector(Guice.java:95)
      	at com.google.inject.Guice.createInjector(Guice.java:72)
      	at hudson.ExtensionFinder$AbstractGuiceFinder.<init>(ExtensionFinder.java:180)
      	at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:149)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
      	at java.lang.reflect.Constructor.newInstance(Unknown Source)
      	at java.lang.Class.newInstance0(Unknown Source)
      	at java.lang.Class.newInstance(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:399)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:110)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:285)
      	at hudson.ExtensionList.load(ExtensionList.java:258)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:229)
      	at hudson.ExtensionList.iterator(ExtensionList.java:136)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:278)
      	at hudson.ExtensionList.load(ExtensionList.java:258)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:229)
      	at hudson.ExtensionList.iterator(ExtensionList.java:136)
      	at jenkins.model.Jenkins.getDescriptorByType(Jenkins.java:1085)
      	at hudson.plugins.copyartifact.BuildSelectorParameter.initAliases(BuildSelectorParameter.java:100)
      	at hudson.plugins.copyartifact.CopyArtifactPlugin.postInitialize(CopyArtifactPlugin.java:35)
      	at hudson.PluginManager$2$1$2.run(PluginManager.java:306)
      	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      	at jenkins.model.Jenkins$5.runTask(Jenkins.java:798)
      	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.TypeNotPresentException: Type hudson.plugins.view.dashboard.DashboardPortlet not present
      	at sun.reflect.generics.factory.CoreReflectionFactory.makeNamedType(Unknown Source)
      	at sun.reflect.generics.visitor.Reifier.visitClassTypeSignature(Unknown Source)
      	at sun.reflect.generics.tree.ClassTypeSignature.accept(Unknown Source)
      	at sun.reflect.generics.visitor.Reifier.reifyTypeArguments(Unknown Source)
      	at sun.reflect.generics.visitor.Reifier.visitClassTypeSignature(Unknown Source)
      	at sun.reflect.generics.tree.ClassTypeSignature.accept(Unknown Source)
      	at sun.reflect.generics.repository.ClassRepository.getSuperclass(Unknown Source)
      	at java.lang.Class.getGenericSuperclass(Unknown Source)
      	at hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule.resolve(ExtensionFinder.java:287)
      	... 39 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.Class.forName0(Native Method)
      	at java.lang.Class.forName(Unknown Source)
      	... 48 more
      WARNING: Failed to load hudson.plugins.cobertura.dashboard.CoverageTablePortlet$DescriptorImpl
      java.lang.LinkageError: Failed to resolve class hudson.plugins.cobertura.dashboard.CoverageTablePortlet$DescriptorImpl
      	at hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule.resolve(ExtensionFinder.java:294)
      	at hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule.configure(ExtensionFinder.java:325)
      	at com.google.inject.AbstractModule.configure(AbstractModule.java:59)
      	at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:223)
      	at com.google.inject.spi.Elements.getElements(Elements.java:101)
      	at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:133)
      	at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:103)
      	at com.google.inject.Guice.createInjector(Guice.java:95)
      	at com.google.inject.Guice.createInjector(Guice.java:72)
      	at hudson.ExtensionFinder$AbstractGuiceFinder.<init>(ExtensionFinder.java:180)
      	at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:149)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
      	at java.lang.reflect.Constructor.newInstance(Unknown Source)
      	at java.lang.Class.newInstance0(Unknown Source)
      	at java.lang.Class.newInstance(Unknown Source)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:399)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:110)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:285)
      	at hudson.ExtensionList.load(ExtensionList.java:258)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:229)
      	at hudson.ExtensionList.iterator(ExtensionList.java:136)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:278)
      	at hudson.ExtensionList.load(ExtensionList.java:258)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:229)
      	at hudson.ExtensionList.iterator(ExtensionList.java:136)
      	at jenkins.model.Jenkins.getDescriptorByType(Jenkins.java:1085)
      	at hudson.plugins.copyartifact.BuildSelectorParameter.initAliases(BuildSelectorParameter.java:100)
      	at hudson.plugins.copyartifact.CopyArtifactPlugin.postInitialize(CopyArtifactPlugin.java:35)
      	at hudson.PluginManager$2$1$2.run(PluginManager.java:306)
      	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      	at jenkins.model.Jenkins$5.runTask(Jenkins.java:798)
      	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.TypeNotPresentException: Type hudson.plugins.view.dashboard.DashboardPortlet not present
      	at sun.reflect.generics.factory.CoreReflectionFactory.makeNamedType(Unknown Source)
      	at sun.reflect.generics.visitor.Reifier.visitClassTypeSignature(Unknown Source)
      	at sun.reflect.generics.tree.ClassTypeSignature.accept(Unknown Source)
      	at sun.reflect.generics.visitor.Reifier.reifyTypeArguments(Unknown Source)
      	at sun.reflect.generics.visitor.Reifier.visitClassTypeSignature(Unknown Source)
      	at sun.reflect.generics.tree.ClassTypeSignature.accept(Unknown Source)
      	at sun.reflect.generics.repository.ClassRepository.getSuperclass(Unknown Source)
      	at java.lang.Class.getGenericSuperclass(Unknown Source)
      	at hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule.resolve(ExtensionFinder.java:287)
      	... 39 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.view.dashboard.DashboardPortlet
      	at java.net.URLClassLoader$1.run(Unknown Source)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.net.URLClassLoader.findClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.ClassLoader.loadClass(Unknown Source)
      	at java.lang.Class.forName0(Native Method)
      	at java.lang.Class.forName(Unknown Source)
      	... 48 more
      

      Attachments

        Issue Links

          Activity

            hopeng Haopeng Huang added a comment -

            i'm getting the same error on 1.437.

            hopeng Haopeng Huang added a comment - i'm getting the same error on 1.437.
            sogabe sogabe added a comment -

            workaround:
            install dashboard view plugin. https://wiki.jenkins-ci.org/display/JENKINS/Dashboard+View.

            Cobertura plugin supports the dashboard view plugin to show trend graph and statistics on dashboard view. but dashboard view plugin is not installed.
            if you don't want to use dashboard view plugin, don't care about it.

            sogabe sogabe added a comment - workaround: install dashboard view plugin. https://wiki.jenkins-ci.org/display/JENKINS/Dashboard+View . Cobertura plugin supports the dashboard view plugin to show trend graph and statistics on dashboard view. but dashboard view plugin is not installed. if you don't want to use dashboard view plugin, don't care about it.
            evernat evernat added a comment - - edited

            it's the same with the emma plugin: JENKINS-8839

            evernat evernat added a comment - - edited it's the same with the emma plugin: JENKINS-8839
            evernat evernat added a comment - I suppose that @Extension(optional = true) could fix this for the cobertura and the emma plugins. See http://groups.google.com/group/jenkinsci-dev/browse_thread/thread/493773519b31f5df and https://github.com/jenkinsci/warnings-plugin/blob/master/src/main/java/hudson/plugins/warnings/dashboard/WarningsNewVersusFixedGraphPortlet.java

            Code changed in jenkins
            User: Seiji Sogabe
            Path:
            src/main/java/hudson/plugins/cobertura/dashboard/CoverageTablePortlet.java
            http://jenkins-ci.org/commit/cobertura-plugin/05dd95998ac64bcf37d959b40a365bf6f4ad83b1
            Log:
            [FIXED JENKINS-11398]Cobertura gives LinkageError in new Jenkins version

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Seiji Sogabe Path: src/main/java/hudson/plugins/cobertura/dashboard/CoverageTablePortlet.java http://jenkins-ci.org/commit/cobertura-plugin/05dd95998ac64bcf37d959b40a365bf6f4ad83b1 Log: [FIXED JENKINS-11398] Cobertura gives LinkageError in new Jenkins version
            dogfood dogfood added a comment -

            Integrated in plugins_cobertura #70
            [FIXED JENKINS-11398]Cobertura gives LinkageError in new Jenkins version (Revision 05dd95998ac64bcf37d959b40a365bf6f4ad83b1)

            Result = SUCCESS
            Seiji Sogabe :
            Files :

            • src/main/java/hudson/plugins/cobertura/dashboard/CoverageTablePortlet.java
            dogfood dogfood added a comment - Integrated in plugins_cobertura #70 [FIXED JENKINS-11398] Cobertura gives LinkageError in new Jenkins version (Revision 05dd95998ac64bcf37d959b40a365bf6f4ad83b1) Result = SUCCESS Seiji Sogabe : Files : src/main/java/hudson/plugins/cobertura/dashboard/CoverageTablePortlet.java

            People

              sogabe sogabe
              dreamtime Angela Johansson
              Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: