Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11774

Mass-configure triggers in Email-Ext-plugin

    XMLWordPrintable

Details

    Description

      A thing I repeatedly have to do for each job is to configure Triggers under the Advanced section of the Editable Email Notification.

      By default, the Email notification will trigger on 'Failure'. However, we also like to receive notification on 'Unstable' and 'Fixed'. Would it be possible to include this somehow in the slicer?

      Attachments

        Issue Links

          Activity

            +1, We noticed to issues while using the two plugins, for us:
            Jenkins: 1.446
            Config slicing plugin: 1.28.1
            Email-ext plugin: 2.16

            First issue was that the Slicer only was modifying the default setting (which we do not use, we use the Failure case almost always.)
            Secondly the default subject and default content was not filled out by default. We started to get a ton of e-mails with no subject nor body. After consulting with the team we realized we'd recently made these changes using the slicer and they were not being filled out.

            wwightman1 William Wightman added a comment - +1, We noticed to issues while using the two plugins, for us: Jenkins: 1.446 Config slicing plugin: 1.28.1 Email-ext plugin: 2.16 First issue was that the Slicer only was modifying the default setting (which we do not use, we use the Failure case almost always.) Secondly the default subject and default content was not filled out by default. We started to get a ton of e-mails with no subject nor body. After consulting with the team we realized we'd recently made these changes using the slicer and they were not being filled out.

            I've added a new ticket to address William's issues
            https://issues.jenkins-ci.org/browse/JENKINS-13834

            jacob_robertson Jacob Robertson added a comment - I've added a new ticket to address William's issues https://issues.jenkins-ci.org/browse/JENKINS-13834
            mklein Michael Klein added a comment -

            I've extended the Slicer to configure the triggers of the Email-Ext-plugin with version 2.18 or higher.
            The attached patch file contains the necessary changes on the code. It would be great, if these changes could find the way into the next release of the Slicer.

            mklein Michael Klein added a comment - I've extended the Slicer to configure the triggers of the Email-Ext-plugin with version 2.18 or higher. The attached patch file contains the necessary changes on the code. It would be great, if these changes could find the way into the next release of the Slicer.
            mklein Michael Klein added a comment -

            Fixed problem with empty email body and subject. An updated patch file is attached.

            mklein Michael Klein added a comment - Fixed problem with empty email body and subject. An updated patch file is attached.

            I tried applying this patch, and in some cases it works, but I noticed I was getting errors like

            javax.servlet.ServletException: java.lang.NoSuchMethodError:
            hudson.plugins.emailext.plugins.EmailTriggerDescriptor.getTriggerName()Ljava/lang/String;
            
            

            So, I upgraded the POM to the latest version of the plugin

            		<dependency>
            			<groupId>org.jenkins-ci.plugins</groupId>
            			<artifactId>email-ext</artifactId>
            			<version>2.34</version>
            			<scope>compile</scope>
            			<optional>true</optional>
            		</dependency>
            
            

            And now the patch has compilation errors in over a dozen places. This is a big challenge with the configuration slicing plugin - it is very hard to keep up with changes to the plugins it slices. If the authors of the email-ext plugin want to maintain the slicer, that would be awesome. But I cannot commit the patch as-is.

            jacob_robertson Jacob Robertson added a comment - I tried applying this patch, and in some cases it works, but I noticed I was getting errors like javax.servlet.ServletException: java.lang.NoSuchMethodError: hudson.plugins.emailext.plugins.EmailTriggerDescriptor.getTriggerName()Ljava/lang/ String ; So, I upgraded the POM to the latest version of the plugin <dependency> <groupId>org.jenkins-ci.plugins</groupId> <artifactId>email-ext</artifactId> <version>2.34</version> <scope>compile</scope> <optional> true </optional> </dependency> And now the patch has compilation errors in over a dozen places. This is a big challenge with the configuration slicing plugin - it is very hard to keep up with changes to the plugins it slices. If the authors of the email-ext plugin want to maintain the slicer, that would be awesome. But I cannot commit the patch as-is.
            iplaman Idan Bidani added a comment -

            I've applied the patch and compiled successfully on the branch "with_triggers"
            you may find only the compilation fix without the error under branch "master"
            https://github.com/iplaman/configurationslicing-plugin

            iplaman Idan Bidani added a comment - I've applied the patch and compiled successfully on the branch "with_triggers" you may find only the compilation fix without the error under branch "master" https://github.com/iplaman/configurationslicing-plugin

            People

              mdonohue mdonohue
              tfnico tfnico
              Votes:
              6 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated: