Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12254

Please add support for variables for page names

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • None
    • Jenkins ver. 1.424.1
      confluence-publisher 1.3
      Atlassian Confluence 3.5.9

    Description

      We have a parameterized job that we would like to post results on different pages depending on the parameters. Please allow the plugin to resolve variable names for the Page names.

      Attachments

        Activity

          jhansche Joe Hansche added a comment -

          The problem I have with this is that I try to do as much auto-detection up front as I can, which is why you see the ajax checks while entering the Space Name and Page Name fields. If using a parameter value in that field, the ajax check will fail, and the job itself will fail if you enter something invalid when initially building the job.

          That said, if there's an error, I agree it's not my problem and caused by the person configuring the job. The goal was just to be helpful up front while configuring it.

          As a last resort, I can just replace the current error with a warning if it detects a "$" in the space or page name. That just means it'll have to be up to you to make sure the parameter is formatted properly when kicking off a build.

          jhansche Joe Hansche added a comment - The problem I have with this is that I try to do as much auto-detection up front as I can, which is why you see the ajax checks while entering the Space Name and Page Name fields. If using a parameter value in that field, the ajax check will fail, and the job itself will fail if you enter something invalid when initially building the job. That said, if there's an error, I agree it's not my problem and caused by the person configuring the job. The goal was just to be helpful up front while configuring it. As a last resort, I can just replace the current error with a warning if it detects a "$" in the space or page name. That just means it'll have to be up to you to make sure the parameter is formatted properly when kicking off a build.
          jhansche Joe Hansche added a comment -

          Implemented in the next release (1.4).

          jhansche Joe Hansche added a comment - Implemented in the next release (1.4).
          jhansche Joe Hansche added a comment -

          Released in version 1.4. It might take a bit for the repository to update.

          jhansche Joe Hansche added a comment - Released in version 1.4. It might take a bit for the repository to update.

          People

            jhansche Joe Hansche
            rmyung Roger Myung
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: