Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12640

Cobertura plugin should not fail maven build for maven release

    XMLWordPrintable

Details

    • Bug
    • Resolution: Fixed
    • Major
    • None
    • Jenkins ver. 1.427 Cobertura Plugin 1.3

    Description

      The cobertura plugin does not play well with maven builds when a maven release is performed

      See https://issues.jenkins-ci.org/browse/JENKINS-4399 where teilo says "Personally I consider this a defect in the corbetrura and clover plugins that
      fails the build if the report isn't there - it should check that the mojo was run during the build and only fail if it ran and the report was empty."

      The plugin works fine for a normal maven build, but when using the "Jenkins Maven Release Plug-in Plug-in" to release a maven build, the cobertura reports would/should not normally be generated but the cobertura plugin fails the release build.

      For example:
      [INFO] ------------------------------------------------------------------------
      [INFO] Reactor Summary:
      [INFO]
      [INFO] aaa-client-parent ............................. SUCCESS [1:30.340s]
      [INFO] aaa-client .................................... SKIPPED cobertura report created here normally but skipped for a release
      [INFO] aaa-client-integration-test ................... SKIPPED
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD SUCCESS
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 1:31.727s
      [INFO] Finished at: Thu Feb 02 12:57:08 GMT 2012
      [INFO] Final Memory: 17M/146M
      [INFO] ------------------------------------------------------------------------

      Publishing Cobertura coverage report...
      No coverage results were found using the pattern '**/target/site/cobertura/coverage.xml' relative to '...'. Did you enter a pattern relative to the correct directory? Did you generate the XML report(s) for Cobertura?
      Build step 'Publish Cobertura Coverage Report' changed build result to FAILURE

      Attachments

        Issue Links

          Activity

            People

              stephenconnolly Stephen Connolly
              azzoti TIm Azzopardi
              Votes:
              5 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: