Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12865

[ERROR] - SEVERE - Polling error Current Project is null from FSTrigger

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Blocker
    • Resolution: Fixed
    • fstrigger-plugin
    • None
    • Linux master (console only no jobs process on it) and a Windows slave

    Description

      I receive the following error when FSTrigger attempts to poll:

      [FSTrigger] - Monitor files

      Polling for the job Output-ICA
      Polling remotely on *****************
      Polling started on Feb 22, 2012 5:58:09 PM
      [ERROR] - SEVERE - Polling error Current Project is null

      I have attached the configuration file though I scrubbed the server name from it. I have tried using \ or / even no path with the same error.

      Attachments

        Activity

          Code changed in jenkins
          User: Gregory Boissinot
          Path:
          src/main/java/org/jenkinsci/plugins/fstrigger/service/FSTriggerComputeFileService.java
          src/main/java/org/jenkinsci/plugins/fstrigger/service/FSTriggerFileNameRetriever.java
          http://jenkins-ci.org/commit/fstrigger-plugin/1032c41949a35c7c2a9eab4e46776d2520918fb7
          Log:
          Fix JENKINS-12865

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Gregory Boissinot Path: src/main/java/org/jenkinsci/plugins/fstrigger/service/FSTriggerComputeFileService.java src/main/java/org/jenkinsci/plugins/fstrigger/service/FSTriggerFileNameRetriever.java http://jenkins-ci.org/commit/fstrigger-plugin/1032c41949a35c7c2a9eab4e46776d2520918fb7 Log: Fix JENKINS-12865

          There was a NullPointerException when the path doesn't exist.
          It seems it was your use case.
          Please upgrade to fstrigger 0.27. The issue should be fixed.

          Do not hesitate to reopen the issue if the problem persists

          gbois Gregory Boissinot added a comment - There was a NullPointerException when the path doesn't exist. It seems it was your use case. Please upgrade to fstrigger 0.27. The issue should be fixed. Do not hesitate to reopen the issue if the problem persists
          bhuggins Brad Huggins added a comment -

          Still receiving the same error with 0.27

          bhuggins Brad Huggins added a comment - Still receiving the same error with 0.27
          bhuggins Brad Huggins added a comment -

          I think I might have found the cause of this issue. It appears that after the Perforce Polling we start seeing this issue. If we don't have Perforce polling or it hasn't run for the 1st time everything works fine with FSTrigger.

          bhuggins Brad Huggins added a comment - I think I might have found the cause of this issue. It appears that after the Perforce Polling we start seeing this issue. If we don't have Perforce polling or it hasn't run for the 1st time everything works fine with FSTrigger.

          Update to Fixed.
          Thanks for your inputs

          gbois Gregory Boissinot added a comment - Update to Fixed. Thanks for your inputs

          People

            gbois Gregory Boissinot
            bhuggins Brad Huggins
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: