Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15048

Git Build Data menu items shows repo URL which kind of disturb the layout

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • git-plugin
    • None
    • Jenkins 1.480, firefox browser, linux

    Description

      As screenshots shows the URL showed are pretty long. Didn't notice this before, seems like a little new bug.

      Using github as repository browser with the https URL for my github project, and the repository url is the one shown in the picture.

      Attachments

        Activity

          markewaite Mark Waite added a comment -

          Refer to JENKINS-15051 for a duplicate of this bug report.

          markewaite Mark Waite added a comment - Refer to JENKINS-15051 for a duplicate of this bug report.
          markewaite Mark Waite added a comment -

          With multiple repositories, it quickly pushes the build related information completely off screen.

          Refer to http://www.flickr.com/photos/markewaite/7956476354/ for an example with 3 repositories.

          markewaite Mark Waite added a comment - With multiple repositories, it quickly pushes the build related information completely off screen. Refer to http://www.flickr.com/photos/markewaite/7956476354/ for an example with 3 repositories.
          markewaite Mark Waite added a comment -

          I submitted a pull request https://github.com/jenkinsci/git-plugin/pull/95 with a fix for this problem.

          markewaite Mark Waite added a comment - I submitted a pull request https://github.com/jenkinsci/git-plugin/pull/95 with a fix for this problem.

          Code changed in jenkins
          User: Mark Waite
          Path:
          src/main/java/hudson/plugins/git/util/BuildData.java
          src/test/java/hudson/plugins/git/util/BuildDataTest.java
          http://jenkins-ci.org/commit/git-plugin/786740dd7a0c469bc48d7bd36bcd0a86fa1b2df3
          Log:
          Fix JENKINS-15048 - shorten build data display name

          Longer display name moves crucial data off screen to the right.

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Mark Waite Path: src/main/java/hudson/plugins/git/util/BuildData.java src/test/java/hudson/plugins/git/util/BuildDataTest.java http://jenkins-ci.org/commit/git-plugin/786740dd7a0c469bc48d7bd36bcd0a86fa1b2df3 Log: Fix JENKINS-15048 - shorten build data display name Longer display name moves crucial data off screen to the right.

          +1 to this problem, by the way, since I noticed it today. Sounds like the fix will be in the next release.

          johnnydude Johnny Kauffman added a comment - +1 to this problem, by the way, since I noticed it today. Sounds like the fix will be in the next release.
          markewaite Mark Waite added a comment -

          Yes, the fix should be in the next release of the git plugin, since the pull request was accepted and merged to the plugin source.

          markewaite Mark Waite added a comment - Yes, the fix should be in the next release of the git plugin, since the pull request was accepted and merged to the plugin source.
          evernat evernat added a comment -

          If the fix is merged, I suppose that this issue is now fixed.

          evernat evernat added a comment - If the fix is merged, I suppose that this issue is now fixed.

          People

            ndeloof Nicolas De Loof
            bue Bue Petersen
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: