Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15196

Plugin uses cleartool.cmd instead of cleartool.exe for Windows slave

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Blocker
    • Resolution: Fixed
    • clearcase-plugin
    • None
    • Windows slave
      Clearcase client 7.0.1.12

    Description

      Actually, issue captured on 1.3.9.
      After upgrade, it seems that plugin assumes cleartool binary to be "cleartool.cmd" instead of cleartool.exe.
      In at least clearcase 7.0.1.12, it results crashes of the plugin (see stacktrace below), even when trying to poll for changes.
      What's also interesting is that the build continues to be triggered all the time, so with eg. 1 minute "quiet period", every 1 minut there is a failed build.

      Building remotely on BarSlave in workspace D:\JenkinsData\workspace\FOO_RELEASE_Integration
      [FOO_RELEASE_Integration] $ "C:\Program Files\Rational\ClearCase\\bin\cleartool.cmd" lsview FOO_jenkins_integration_release
      [INFO] computeChangeLogBeforeCheckout = false
      [INFO] computeChangeLogAfterCheckout = false
      [FOO_RELEASE_Integration] $ "C:\Program Files\Rational\ClearCase\\bin\cleartool.cmd" startview FOO_jenkins_integration_release
      java.io.IOException: Cannot run program "C:\Program Files\Rational\ClearCase\\bin\cleartool.cmd" (in directory "D:\JenkinsData\workspace\FOO_RELEASE_Integration"): CreateProcess error=2, The system cannot find the file specified
      at java.lang.ProcessBuilder.start(Unknown Source)
      at hudson.Proc$LocalProc.<init>(Proc.java:244)
      at hudson.Proc$LocalProc.<init>(Proc.java:216)
      at hudson.Launcher$LocalLauncher.launch(Launcher.java:709)
      at hudson.Launcher$ProcStarter.start(Launcher.java:338)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:934)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:901)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:287)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at hudson.remoting.Engine$1$1.run(Engine.java:60)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
      at java.lang.ProcessImpl.create(Native Method)
      at java.lang.ProcessImpl.<init>(Unknown Source)
      at java.lang.ProcessImpl.start(Unknown Source)
      ... 17 more
      [xUnit] [INFO] - Starting to record.
      [xUnit] [INFO] - Processing NUnit-Version N/A (default)

      Attachments

        Activity

          Code changed in jenkins
          User: Vincent Latombe
          Path:
          src/main/java/hudson/plugins/clearcase/ClearCaseInstallation.java
          http://jenkins-ci.org/commit/clearcase-plugin/aaf02015adff5ee47f63cac590a077594c24ac1d
          Log:
          [FIX JENKINS-15196] Plugin uses cleartool.cmd instead of cleartool.exe
          for Windows slave

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Vincent Latombe Path: src/main/java/hudson/plugins/clearcase/ClearCaseInstallation.java http://jenkins-ci.org/commit/clearcase-plugin/aaf02015adff5ee47f63cac590a077594c24ac1d Log: [FIX JENKINS-15196] Plugin uses cleartool.cmd instead of cleartool.exe for Windows slave

          Fixed in 1.3.10.1

          vlatombe Vincent Latombe added a comment - Fixed in 1.3.10.1

          People

            vlatombe Vincent Latombe
            weakcamel Waldek M
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: