Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16774

URLTrigger gives severe error message instead of detecting change

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: urltrigger-plugin
    • Labels:
      None
    • Environment:
      Ubuntu 10.04, Jenkins 1.500, Jenkins URLTrigger Plug-in 0.27.
    • Similar Issues:

      Description

      The URLTrigger gives severe error instead of detecting change. From trigger log:

      [URLTrigger] - Poll with a URL

      Inspecting Monitor a change of the content content for URL http://build.netinsight.se/autobuild/dev/acf/continuous/release/

      Polling started on 2013-feb-12 12:12:12
      Polling for the job dev-acf
      Looking nodes where the poll can be run.
      Looking for a candidate node to run the poll.
      Looking for a node with no predefined label.
      Trying to poll with the last built on node.

      Polling on master.
      [ERROR] - SEVERE - Polling error null

      I think this problem started after restart (and possibly upgrade of Jenkins and URLTrigger plugin). Updating the configuration doesn't help, but if manually run once, it seems to start working again.

      Attached is the config.

        Attachments

          Activity

          dmeibusch dmeibusch added a comment -

          @gregory - thanks for the response. Upgraded Rebuild Plugin appears to have fixed the issue.

          dmeibusch dmeibusch added a comment -

          And now the issue has re-appeared on other builds - I'll raise a new issue with details.

          gbois Gregory Boissinot added a comment -

          Please check in the stack trace if the issue is relative to URLTrigger or Rebuild plugin (as in the above stack trace).
          Thanks in advance

          dmeibusch dmeibusch added a comment -

          @gregory - Rebuild plugin update fixed the issue (re: stack trace above). I raised a new ticket, JENKINS-17145, with a new stack trace.

          gbois Gregory Boissinot added a comment -

          thanks


            People

            Assignee:
            gbois Gregory Boissinot
            Reporter:
            magjac Magnus Jacobsson
            Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: