Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18094

Xvfb plugin doesn't write any error message in build log

    XMLWordPrintable

Details

    Description

      If in time when we create Xvfb display we got any error plugin doesn't write about it error in build log.

      Error example:
      _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
      _XSERVTransMakeAllCOTSServerListeners: server already running

      Fatal server error:
      Cannot establish any listening sockets - Make sure an X server isn't already
      running

      Attachments

        Activity

          zregvart zregvart added a comment -

          Does the option to Log Xvfb output help? It's in in the advanced settings of the plugin in the job configuration.

          zregvart zregvart added a comment - Does the option to Log Xvfb output help? It's in in the advanced settings of the plugin in the job configuration.

          I saw this option, but I still have no err messages in log and Xvfb does not mark build as failed.

          voodoo144 Aleksey Alekseev added a comment - I saw this option, but I still have no err messages in log and Xvfb does not mark build as failed.

          Code changed in jenkins
          User: Zoran Regvart
          Path:
          src/main/java/org/jenkinsci/plugins/xvfb/XvfbBuildWrapper.java
          src/main/resources/org/jenkinsci/plugins/xvfb/Messages.properties
          http://jenkins-ci.org/commit/xvfb-plugin/7f2d3b3ae412130a6d90c8a073873c1a5e504c98
          Log:
          JENKINS-18094 Xvfb plugin doesn't write any error message in build log

          Compare: https://github.com/jenkinsci/xvfb-plugin/compare/29e042605ea4...7f2d3b3ae412

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Zoran Regvart Path: src/main/java/org/jenkinsci/plugins/xvfb/XvfbBuildWrapper.java src/main/resources/org/jenkinsci/plugins/xvfb/Messages.properties http://jenkins-ci.org/commit/xvfb-plugin/7f2d3b3ae412130a6d90c8a073873c1a5e504c98 Log: JENKINS-18094 Xvfb plugin doesn't write any error message in build log Compare: https://github.com/jenkinsci/xvfb-plugin/compare/29e042605ea4...7f2d3b3ae412
          zregvart zregvart added a comment -

          I've made the change that fails the build and outputs standard error and standard output to the build console log even if no Xvfb output is wanted (the log Xvfb output checkbox under Advanced) – if the Xvfb process is not alive after starting or after the wait timeout (configurable option). If you find the alive check to be too soon try setting the timeout in seconds to 1-2 seconds.

          Also I have increased the requirement for jenkins core, the minimal jenkins version you need to be running to 1.424.6 (LTS of March 2012).

          Aleksey, would you mind testing a snapshot version of the plugin, so that I can be sure that this issue is resolved before release?

          The snapshot is at: https://dl.dropboxusercontent.com/u/4210293/xvfb-1.0.8-SNAPSHOT.hpi

          thanks

          zregvart zregvart added a comment - I've made the change that fails the build and outputs standard error and standard output to the build console log even if no Xvfb output is wanted (the log Xvfb output checkbox under Advanced) – if the Xvfb process is not alive after starting or after the wait timeout (configurable option). If you find the alive check to be too soon try setting the timeout in seconds to 1-2 seconds. Also I have increased the requirement for jenkins core, the minimal jenkins version you need to be running to 1.424.6 (LTS of March 2012). Aleksey, would you mind testing a snapshot version of the plugin, so that I can be sure that this issue is resolved before release? The snapshot is at: https://dl.dropboxusercontent.com/u/4210293/xvfb-1.0.8-SNAPSHOT.hpi thanks

          Ok, I will test this build, and write down results.

          voodoo144 Aleksey Alekseev added a comment - Ok, I will test this build, and write down results.

          I test it on ~100 builds. Everything is fine )

          voodoo144 Aleksey Alekseev added a comment - I test it on ~100 builds. Everything is fine )
          zregvart zregvart added a comment -

          Thank you very much for reporting and testing this bug. I've released 1.0.8 with the fix outlined in comment 4.

          zregvart zregvart added a comment - Thank you very much for reporting and testing this bug. I've released 1.0.8 with the fix outlined in comment 4 .
          zregvart zregvart added a comment -

          fixed in 1.0.8

          zregvart zregvart added a comment - fixed in 1.0.8
          zregvart zregvart added a comment -

          Closing resloved issues

          zregvart zregvart added a comment - Closing resloved issues

          People

            zregvart zregvart
            voodoo144 Aleksey Alekseev
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: