Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18238

Symbolic link is not updated after publishing build

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: build-publisher-plugin
    • Labels:
      None
    • Environment:
      internal jenkins:
        build-publisher: 1.12
        Jenkins ver. 1.510
      external jenkins
        Jenkins ver. 1.510
    • Similar Issues:

      Description

      On pushing a build onto an external jenkins, symbolic links are not updated.
      e.g. the symbolic link jenkins/jobs/jobName/builds/lastSuccessfulBuild is still directing to #1361 even though successful build #1365 is already pushed.
      as a result the web interface is showing the wrong build in Last Successful Artifacts (www.MyJenkinsServer/job/jobName/label=labelXY/lastSuccessfulBuild/artifact/)

      if i delete the symbolic link and restart jenkins, a link to the latest build is created but is not updated during the further procedure.

      lrwxrwxrwx 1 jenkins jenkins 4 6. Jun 12:20 lastSuccessfulBuild -> 1361

        Attachments

          Activity

          sroth Steve Roth added a comment -

          We are seeing this as well.

          tiainpa tiainpa added a comment -

          if i delete the symbolic link and restart jenkins, a link to the latest build is created but is not updated during the further procedure.

          We are facing this issue too, but for the quoted statement I have to say that it is enough to delete the symbolic link and just trying to access the URL related to the link. At least in our case Jenkins automatically updates the symbolic link to point to the correct build.

          shermdog Rick Sherman added a comment -

          I've tried digging into this, but haven't been able to figure out the root cause. Has anyone else made progress on this?

          shermdog Rick Sherman added a comment -

          Submitted a pull request to address this issue. It will most likely need to be reviewed.

          https://github.com/jenkinsci/build-publisher-plugin/pull/6

          vjuranek vjuranek added a comment -

          Fixed by PR #6, released in build published 1.19.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Rick Sherman
          Path:
          src/main/java/hudson/plugins/build_publisher/ExternalProjectProperty.java
          src/main/java/hudson/plugins/build_publisher/HTTPBuildTransmitter.java
          http://jenkins-ci.org/commit/build-publisher-plugin/974eb0135b9830de84d8b9539487e6c42e83cbcc
          Log:
          Fix for JENKINS-18238

          Updated code to create symlink for the build (based on private instances
          build number) as well as update the PeepHolePermalinks.

          This should resolve:
          JENKINS-18238
          JENKINS-6096

          And may influence:
          JENKINS-18105


            People

            Assignee:
            lvotypkova Lucie Votypkova
            Reporter:
            stefan_rohleder Stefan Rohleder
            Votes:
            5 Vote for this issue
            Watchers:
            8 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: