Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18272

Expose key maven properties (such as GAV IDs) as build variables

    XMLWordPrintable

Details

    • New Feature
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • maven-plugin
    • None

    Description

      ... so that one can use it as variables in the post-build actions.

      Attachments

        Issue Links

          Activity

            Pull request containing a possible solution to this here: https://github.com/jenkinsci/jenkins/pull/933

            christoe Christoffer Kylvåg added a comment - Pull request containing a possible solution to this here: https://github.com/jenkinsci/jenkins/pull/933

            Code changed in jenkins
            User: Kohsuke Kawaguchi
            Path:
            src/main/java/hudson/maven/MavenModule.java
            src/main/java/hudson/maven/MavenModuleSetBuild.java
            http://jenkins-ci.org/commit/maven-plugin/59afb8b94eade3b29de98103d914ec487c128814
            Log:
            [FIXED JENKINS-18272]

            Expose various key properties of POM as environment variables.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Kohsuke Kawaguchi Path: src/main/java/hudson/maven/MavenModule.java src/main/java/hudson/maven/MavenModuleSetBuild.java http://jenkins-ci.org/commit/maven-plugin/59afb8b94eade3b29de98103d914ec487c128814 Log: [FIXED JENKINS-18272] Expose various key properties of POM as environment variables.
            kutzi kutzi added a comment -

            Is a new feature and not a bug

            kutzi kutzi added a comment - Is a new feature and not a bug

            People

              Unassigned Unassigned
              kohsuke Kohsuke Kawaguchi
              Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: